Keep getting ERR_ICANN_NAME_COLLISION

this is on windows.
I tried using .local
Same problem, just gives a slightly different error.
ERR_NAME_NOT_RESOLVED

The problem is the fake SSL certificate that Local and/or DesktopServer adds to your system.

Problems with the fake SSL certificate stops Chrome from accessing my local sites, for example, with the ERR_ICAN_NAME COLLISION or other error message that the site could not be accessed.

If you are using a Mac, go to Keychains, search for your websitename.dev fake SSL certificate, delete it, then you should now have access.

Until issues with fake SSL certificates are resolved, either avoid using Local’s fake SSL certificate feature or keep deleting the certificates whenever you have a problem.

I am not using Mac, I am using Windows as metnioned.
I removed the SSL, but it didn’t help.

It sounds to me like your hosts file isn’t getting updated. What version of Windows are you on again?

For now, you can manually update it by pointing the local domain to Local’s Docker Machine IP. To get the IP of the Local machine, you can click on any Local site then go to the Database tab and note what the Remote Host is.

Here’s a quick guide on how to do add it to the hosts file if needed:

The purpose of the hosts file is to bypass DNS lookup, so your computer looks here first before it sends the requests off to the DNS servers listed in your work settings. This is what allows you to use a fake domain or point a domain somewhere other than where it is really hosted.

the hosts file entry doesn’t continuously change, the entries only need updating if you have changed the domain (host header) used for the website or the destination IP address has changed. Since neither of these has changed, there is nothing that needs updating. The NAT IP address on the VM is static not dynamic.
Also please do note that If the entry was missing or wrong, then the website would have NEVER worked period, it could not be intermitant, and restarting the site would have no effect, since without the hosts file entry, it would never resolve the virtual machine, it would always try to do a dns lookup on the internet and fail.

Hi all,

Please see Missing Hosts entry.This site may be inaccessible.

I installed this on both my machine and my sons, but we have both continued to have the same issue that we have to keep restarting the site.
This is more of a problem for my son, because he is not an administrator on his pc, which means every time he has to restart a site, it requires an administrator password for node.js, not sure why.

@snake,

Do you and your son have some type of internet security, anti-virus, anti-malware, etc (apologies if I’ve asked this in another thread)?

I know most typically lock the file, but it almost sounds like something is intermittently reverting the changes in the hosts file. Is there any way you can check the contents of the hosts file after this issue pops up?

Yes we have AV software, I use BitDefender.

I think you are still misunderstanding how the hosts file works. Here is my previous reply from June 9th above. Nothing is being reverted or removed from the hosts file.

The purpose of the host’s file is to bypass DNS lookup, so your computer looks here first before it sends the requests off to the DNS servers listed in your work settings. This is what allows you to use a fake domain or point a domain somewhere other than where it is really hosted.

the hosts file doesn’t continuously change, it only changes if the entries need updating, which would happen if you have changed the domain (host header) used for the website or the destination IP address has changed, or you add a new site and thus need to add a new entry. Since none of this has changed, there is nothing that needs updating in the hosts file. The NAT IP address on the VM is static not dynamic.
Also please do note that If the entry was missing or wrong, then the website would NEVER work period, it could not be intermitantly right then wrong, and restarting the site would have no effect on this, since without the hosts file entry, it would never resolve the virtual machine, it would always try to do a dns lookup on the internet and fail.

The reason why you’re getting ERR_ICANN_NAME_COLLISION is due to the hosts file not taking effect on either the system-level or in the browser level. I’m not sure which, but you can probably find out by running a ping command to see if it matches the entry in the hosts file. If it matches, then it may be something pertaining to the browser.

If it was properly using the hosts file entry, then you should at the very least be seeing an error along the lines of ERR_CONNECTION_REFUSED or ERR_CONNECTION_TIMED_OUT.

Also, you mentioned getting the ERR_NAME_NOT_RESOLVED error when using .local. Again, this is happening because your hosts file is not taking effect. The reason why the error is different is due to .dev being a TLD. If you ping the .dev domain, you’ll most likely get 127.0.53.53 as a response.

Clay,

I have been using the hosts file for nearly 20 years, 16 of which I owned a hosting company, and previous to that I was a developer, so I been using it personally for development, and resolving sites during migration or while testing sites on different hosts etc. I have also been advising customers on how to use the hosts file for a very long time.

As I have already pointed out several times, If the hosts file was not taking effect, then it would NEVER work, this would be a permanent issue. It wouldn’t just work one minute and then stop working the next minute.
Ping works just fine and the fake domains from my hosts file resolve to the IP address of the virtual machine as expected.
I also have IIS installed, and I have no problems whatsoever with sites setup here, they work all day long, no random intermittent issues. The only issue is with LOCAL BY FLYWHEEL.

I don’t really know how else I can explain this that will make more sense.

Have you inserted entries directly in the hosts file that match sites in Local by Flywheel? If so, are you able to access the site?

This is happening because Local isn’t seeing the entries in the hosts file in the format that it expects.

Is there any way you can provide yours or your son’s host file after Local tries to edit it? I’m curious if there’s something throwing off the pattern matching. Feel free to private message it to me.

yes and I have already answered this many times now, we are just going round in circles with you asking me the same questions repeatedly. Read my last reply.

Sorry about that, the thread has gone on for quite some time and it’s hard to remember every detail.

Please see the following in my last reply:

make sure your antivirus software is not blocking the changes that LOCAL is making to the hosts file. Most decent AV products do monitor this file for suspicious changes. As I have just discovered, Bitdefender seems to detecting the changes made by local as it seems to edit the file frequently, and blocking them or commenting them out. Then when you restart, LOCAL puts the changes back again.

@snake,

Glad you found it :smiley:

Which Bitdefender product are you using? I didn’t see a hosts option in their free AV.

What steps are needed to fix this as I’m using bitdefender as well and running into this issue.

Thank you

u have to stop it monitoring the hosts file

1 Like

Thanks for the reply @snake. How did you go about doing so. Tried to exclude the file but still seems to run on the host file.

You just go into the BitDefender settings and change “scan hosts file” to off.

Although this is not ideal to leave it off, as hijacking your host’s file is a common tactic of malware. So I’d turn it back on again after LOCAL has finished making changes to it.

1 Like