Local Community

Lightning Services Missing (reopened)

I just updated to 6.2.0 and have a “Lightning Services Missing” notification that seems to stop me from launching any local sites. I see that the issue was raised a couple years back but, was archived due to lack of activity. Any pointers?

Continuing the discussion from Lightning Services Missing:

Issue Summary

One or two sentence summary of the issue.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

2 Likes

I have experienced the same thing. After updating the software.

I just updated to 6.2.0 and was in total panic because of that error. I found only APPLY button on the app, the one near PHP version. I didn’t change the version, just clicked APPLY and it downloaded same version and installed it. I guess they added those lighting extensions to php. Now everything works as before.

4 Likes

thank you! I saw the error and had no idea where to click - it doesn’t say “lightning” anywhere on the screen except in the error message.

Panic panic … I have the same issue here but I just don’ t know where to click the apply button on my installed programm on windows 10. Can you please help me? Thanks in advance!

That worked for me as well. Perhaps the error message should present this information.

1 Like

Check if you can see an Apply button next to the PHP-version in the sites window. That is where I found it and Local now works again.

1 Like

You r the best. Kinda hidden option. It finally works! Relieved …

+1 on the adding further instructions!

Don’t thank me, thank mariomarusic who had the solution.

This too helped me out today, THANK YOU! Everything had stopped working after installing update. The APPLY button next to the PHP version is the key for local to be up and working on a mac. Sorry, I don’t have a windows version to see if it is the same solution.

Mine is on windows, and it is the solution, yes.

Thanks, same problem and same solutions
I just missed to see the button ‘APPLY’ next to PHP , I clicked it and now it works fine again.

Sorry everyone for the confusion everyone!

For background on why this was changed, we updated the preferred environment to use the PHP 7.4.x version as opposed to the 7.3.x version so that it meets WordPress’ recommended version:

Because 7.3.x was the former preferred version, it was no longer present in the new build, which is why clicking ‘apply’ was able to download the missing service.

Hey,
I have the same issue, Can you please tell me step by step how to fix this?

SAME EXPERIENCED I just updated to 6.2.0 and have a “Lightning Services Missing’’ issue , I can’t start site and Wordpress version is not showing…Can anybody help me please ?

A post was merged into an existing topic: Your Lightning services are missing… Click “Apply” next to the missing service(s) to update

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.