Local Community

Your Lightning services are missing... Click "Apply" next to the missing service(s) to update

Issue Summary

After updating Local, I am unable start sites. I see “Your Lightning services are missing… Click “Apply” next to the missing service(s) to update.” I do not see “Apply” or anything that says “Lightning services.”

I reviewed your documentation and other recent relevant help tickets. Found no guidance.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    All sites in Local

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?
    No, the process timed out and the application froze. I killed the Local app, restarted, and the new site appears and runs.

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

  1. Update Local
  2. Try to start or create a site

System Details

  • Which version of Local is being used?
    Latest

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
      Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Moderator Note

Sorry for the confusion, and thanks for all of the feedback! We (the Local team) realize that we talk about Lightning Services all day, but it doesn’t mean much to our end users :man_facepalming: !

You can think of Lightning services as the individual pieces of server software that run a site. In this case, our update changed the default version of PHP to 7.41 for the preferred environment, which meant that any site that was using the 7.3.5 version was missing it!

As others have mentioned, the fix is to click the “Apply” button next to the PHP version to re-download that missing Lightning Service!

Thanks again for using Local and helping the community get back on track!

1 Like

I can also confirm that this issue happens on Macs as well. It happened after updating to 6.2.0+5679

In File menu there is an item called services. This one is empty on Mac. Not sure if it is empty on Windows.

Any progress on this? I’m getting it too.

Fixed after clicking the apply link next to the PHP version.

You might need to toggle the drop down to get it to show.

5 Likes

Thanks for pointing this out. One click fixes are the best :v:

1 Like

I just updated to 6.2.0 and have a “Lightning Services Missing” notification that seems to stop me from launching any local sites. I see that the issue was raised a couple years back but, was archived due to lack of activity. Any pointers?

Continuing the discussion from Lightning Services Missing:

Issue Summary

One or two sentence summary of the issue.

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

Replication

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!

System Details

  • Which version of Local is being used?

  • What Operating System (OS) and OS version is being used?

    • For example: macOS Catalina or Windows 10 Professional
  • Attach the Local Log. See this Help Doc for instructions on how to do so:

Security Reminder

Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

2 Likes

When I reinstalled Local by Flywheel I get a red bar that states “Your Lightning services are missing… Click Apply next to the missing service(s) to update”. When I go to Local menu and select Services it is empty. How do I even install Lightning services?
Thanks

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

When I reinstalled Local by Flywheel I get a red bar that states “Your Lightning services are missing… Click Apply next to the missing service(s) to update”. When I go to Local menu and select Services it is empty. How do I even install Lightning services?
Thanks

1 Like

I’m having this same error after Local updated on my Windows machine.

Hey ,
I have the same issue . Any suggestion?

Solution here: Lightning Services Missing (reopened)

Check if you can see an Apply button next to the PHP-version in the sites window. That is where I found it and Local now works again.

1 Like

I didn’t have the “Apply” button, until I upgraded to 6.2.1 here… https://localwp.com/releases/

Hey,
Whenever they updated locally on machine they show error.