Local Community

Linux client - Errors on mySQL

Hello, I tried to install the new .deb client in two different distros. In all distros, I received errors in mySQL.

In Deepin, you can create a new server / site, but when we try to start this site, we can only see the default Apache page. Pop-ups notify me about mySQL errors.

In Kubuntu 19.04, I received that mySQL messages during site creation and Local always abort the process.

Hi there! We’re working to improve the Linux install experience.
In the meantime, can you try running:

sudo apt-get install -y libaio1

Then, run the Local Linux deb installer again. Did that help?


One more package worth trying to install is libncurses-dev. We’ll be sure to make sure this is a listed dependency in the deb.

Thank you guys, I’ll try this tonight. I’m on Mac OS environment now.

Hey @clay and @flyjack

I tried to install all packages but …!

Well… I will wait for the next update…

Thanks for giving it a shot! I’ll trying the Linux distros you mentioned and see if I can’t reproduce the issue myself.


I just spun up a VM of Kubuntu 19.04 and I was able to get it running with the following:

sudo apt-get install -y libncurses5 

I wasn’t sure whether I should start a new thread or not but let’s start here. First, thank you for improving performance and providing an option for Linux. I had been using Local a while ago but had a multitude of issue, performance being one. I also moved to Linux around that time.

So, I installed the packages you’ve suggested but am seeing a different error (below). I checked and, as the error suggests, the file doesn’t exist. I am on Kubuntu 19.04. mysql is installed according to dkpg. Any assistance is appreciated. Thanks!



It looks like we’re getting somewhere!

Can you provide the local-lightning.log file? It should give us more insight into what happened prior to the error in the dialog.

See How do I retrieve Local's log file?

Sure. Here you go.local-lightning.log (54.7 KB)

Thanks! It looks like it’s getting hung up on a port allocation issue:

{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2019-09-13T17:30:45.986710Z 0 [ERROR] [MY-010262] [Server] Can't start server: Bind on TCP/IP port: Cannot assign requested address","timestamp":"2019-09-13T17:30:45.989Z"}
{"thread":"main","class":"Process","process":"mysql","level":"warn","message":"2019-09-13T17:30:45.986721Z 0 [ERROR] [MY-010257] [Server] Do you already have another mysqld server running on port: 10003 ?","timestamp":"2019-09-13T17:30:45.990Z"}

Is there anything running on port 10003? https://www.tecmint.com/find-out-which-process-listening-on-a-particular-port/ has some good pointers to see how to check.

@clay might this have anything to do with my issue re: mysqladmin not needing the parameters to create a database and actually choking when they were given?

That above error dialog seems to have similar wording to my CLI errors.

Thanks for pointing me in the right direction. It was a vpn client with a firewall running in the background. I disabled it and all is well. Thanks again for your help!

1 Like


That’s surprising that a VPN caused the conflict! Was it on the port Local’s MySQL was trying to bind on?

According to the VPN provider, their firewall “blocks all connectivity outside of the tunnel to ensure there is zero chance of any kind of leak, including but not limited to DNS leaks, IPv6 leaks, WebRTC leaks, etc.”. Based on that, I assume it was blocking everything. There is a LAN Bypass option but I’m not sure if I had it enabled. Maybe it’s just too aggressive.

Got it. It does bind on ::1 in addition to so you may be on the right track with the IPv6 thing.

I’ll test this out with a couple of popular VPN providers and see what we find.

Thanks again for the details!

1 Like