Uh-oh! Unable to start site. (Error in creating my first site on local)

I installed local on ubuntu 22.04 and tried creating a new site and it throughs error
local version 8.1.0.deb
os Ubuntu 22.02

Screenshot from 2023-11-13 00-06-00

I have just installed a recent version of Local (Version 8.1.0+6514) on Linux Mint ‘Victoria’ 21.2 then tried to create a site and it’s running without problem.
It looks like there might be an issue with the MySQL server that Local is trying to use for your site. The error message indicates that it can’t connect to the local MySQL server through the specified socket.
Have you checked your MySQL status?

sudo service mysql start

then verify if the MySQL socket file mentioned in the error message exists:

ls /home/snake/.config/Local/run/4qqHUVix5/mysql/mysqld.sock

If the file doesn’t exist, it could mean that MySQL hasn’t created the socket, or it’s in a different location.


Hey Rebarakaz, thank you for responding.
I followed the path given in error to check the socket file, and couldn’t find /4qqHUVix5 and onwards, after /run folder. What could be the possible error?

Cross sharing this thread with one of our Local Devs that might provide some helpful information as well. If you have related questions or concerns you can also share over there as well:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.