Local Community

Live Links Broken due to expired SSL certificate

I am trying to show a website to my client and i am using the live link feature which has been working until this morning.

Everytime I try to enable Link Link, I get this error:

Uh-oh! Could not start Live Link.
Error: certificate has expired
at TLSSocket.onConnectSecure (_tls_wrap.js:1497:34)
at TLSSocket.emit (events.js:315:20)
at TLSSocket._finishInit (_tls_wrap.js:932:8)
at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:706:12)

Is there a fix for this? I am under a deadline and need to show my client asap!

Help!

1 Like

I am getting the same error and also working with a client. Ugh. Support said it is affecting everyone and is working on it.

Thank you for the reply! Glad to hear its not just me! Would love any updates as your day continues.

Hello,
today i started local and it won’t let me activate the “line link”
Returns the “Error: certificate has expired” message.

I went to the Mac keychain, deleted the certificate, then went back to “Local” and clicked on “Trust” to recreate the certificate.
“Local” has recreated the certificate but “line link” keeps giving the same error. In any case, the certificate has not expired and it will expire: Saturday 27 September 2031.

I attach image
error Line link

Thank you

I forgot I also updated Local to the latest version 6.1.3 + 5515

Any resolution for this? I’m experiencing the same issue.

1 Like

Getting the same issue here today.

1 Like

Having a similar issue here when trying to Live Link. It’s not exactly the same, but it started today.

I tried:
Re-trusting the SSL
Resetting the server.
Resetting the software.
Resetting PC.

image

1 Like

Same problem here! Refering to bruno_self:s reply…=)
Did all the Re***** also!
error-local

1 Like

Same problem here too

image

1 Like

I have the same issue… Is anyone working on getting this fixed? I have a client that wants to view their site

Hi everyone, I’ve consolidated as many of the replies that I know of around Live Links being broken due to an expired certificate.

The Local team is taking a look and should have more info soon. Initially, it seems like it is an issue with Let’s Encrypt and one of their certificates higher up the chain.

If you are needing to share work, for example with a client, the quickest route would be to deploy the site somewhere. Using Connect to Flywheel is pretty easy, and they allow a demo site to be spun up which means not cost to you upfront.

Sorry for the inconvenience, but we’re working on getting things back up and running!

1 Like

Thanks for the info and potential solution/workaround.

Could you please let us know when this is resolved?

Definitely! I’ll reply to this topic as I know more!

1 Like

Sounds good and I will try out Connect to Flywheel if it is possible to use a demosite for a while.

Just checking in… No solution yet, but the specific problem has been identified, and our infrastructure team is exploring possible solutions!

I am also getting this error.
Local not working

Same problem here. Any updates?

Hi Ben. Any update on when the SSL certificate issue for Live Link might be fixed?

Similar here. Mac OSX catalina. None of the WP sites creates live links. Even new ones.