Local by Flywheel suddenly became very slow for me after an update.

It would load items from the sidebar of the Wordpress Dashboard in 12+ seconds rather than immediately.
Websites would take 12+ seconds to load pages. This was insane.

It was driving me nuts. It would be faster simply to develop online than on Local.

I had updated to Local by Flywheel 2.2.4 on a MacBook Pro 15" Retina Late 2013 16GB RAM, 1 TB SSD, MacOS Sierra 10.12.6.

This bug even made me think about getting a new MacBook Pro - but I’m waiting for MacBook Pros with the new Intel i7 CPUs with 6 CORES and 32 GB RAM before I would ever update. 4-CORES and 16 GB is simply get too often saturated when running 32 apps for work. And Intel CPUs haven’t gotten much faster in the past 7 years.

Another clue:
When trying to clone a website, it would give an error message that SQL couldn’t access the database.

The following failed to speed up Local by Flywheel:

  1. turning on Faster Docker Volumes
  2. turning on IPv6 Loopback
  3. Turning on or off Developer Mode
  4. Upgrading VirtualBox to 5.2.8
  5. Upgrading PHP Version to 7.2.0

What I found was a bug in Local By Flywheel.

Correcting this bug restored the speed of developing on Local.


Local by Flywheel was setting the PERMISSIONS of the SQL directory incorrectly for each new website.

The location of the SQL directory for each website is:

/Users/youraccount/Documents/Websites by Local/mywebsitename/app/sql/

The permission for this directory is INCORRECTLY set to: drwx------ (700)

Instead the permission for this directory should be: drwxr-xr-x (755)

Older SQL directories had 755 as the permission setting.

Once I corrected the permissions error manually for each new website that Local 2.2.4 created, Local was restored to working as fast as it was before!

Using Path Finder makes this easy. Just change the 700 to 755 in the get-info dialog for the directory.

I can get to the sql folder - but where/how do you set/change permissions?

A folder or file’s permissions settings are a function of the file system.
On a Mac these are a folder or file’s UNIX permissions settings.
To set them, you have to use an app that allows you to see them.
The Mac Finder doesn’t do a good job of this. It gives you a simplified version when you Get Info.

You can see and folder and file UNIX Permissions using the app Path Finder. Use Path Finder’s Get Info for the selected folder or file.

BatChmod is a free utility that also allows you to set UNiX Permissions on selected files and folder.

Does anyone know how to do this on the windows 7 system?

I found instructions to change permissions to 755 here:

Hi have you tried with the latest 2.3.0 pre release?

Hey Romeo,

Thanks for all of the details! It’s definitely interesting.

The app/sql folder is only used for SQL exports. The only time it’s accessed/modified is when you export the site or stop the site.

My guess is that when you change the permissions it’s either priming or refreshing the file system cache (either NFS or VirtualBox shared folders).

If this happens again, try opening Terminal and running ls -laR LOCAL_SITE_PATH > /dev/null (Example: ls -laR ~/Local\ Sites/test > /dev/null) instead of trying to change the permissions.