"Local couldn't load the file list" error since updating to 8.2 for Local Connect

What issue or error are you experiencing?

Unable to pull/push using Local Connect to WPE sites upon upgrading to 8.2. Receive the following in logs:

{“class”:“CAPIService”,“level”:“error”,“message”:"Error creating new SSH key: ",“thread”:“main”,“timestamp”:“2024-01-10T17:21:47.356Z”}
{“class”:“RsyncService”,“level”:“warn”,“message”:“Cannot access install \r\n”,“thread”:“main”,“timestamp”:“2024-01-10T17:21:48.315Z”}
{“class”:“RsyncService”,“level”:“warn”,“message”:“rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]\nrsync error: error in rsync protocol data stream (code 12) at io.c(231) [Receiver=3.2.7]\n”,“thread”:“main”,“timestamp”:“2024-01-10T17:21:48.315Z”}
{“class”:“WPEPullService”,“level”:“error”,“message”:"Error in WP Engine connect: ",“sentryEventId”:“a143a8be89b64eaaa89f9207a8954a9c”,“thread”:“main”,“timestamp”:“2024-01-10T17:21:48.317Z”}
{“class”:“WPEPullService”,“level”:“error”,“message”:“rsync process existed with code 12”,“stack”:“Error: rsync process existed with code 12\n at ChildProcess. (%%appPath%%\main\rsync\RsyncService.js:1:1548)\n at ChildProcess.emit (node:events:513:28)\n at ChildProcess._handle.onexit (node:internal/child_process:291:12)”,“thread”:“main”,“timestamp”:“2024-01-10T17:21:48.317Z”}

This issue appears to be very similar to this but solutions in that thread have not helped: Local couldn't load the file list / Unable to pull or connect to WPE sites - #4 by jhenrywaugh

Please advise!

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:
    8.2
  • Operating System (OS) and OS version:
    Windows 11

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @amida

If you downgrade to 8.1 does that work?

Can you share you full logs for us here as well? There are some different ways to access and share Local Logs. For us to be able to troubleshoot thoroughly, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

Hi @Nick-B thank you for your response. Attached the log files:
local-logs.zip (798.8 KB)

Downgraded to 8.1 and the following occurred:

  • Initially re-entering the API credentials resulted in the app getting stuck at submitting SSH key. Closing the window showed that somehow it was actually connected.
  • I have an existing site that was already connected prior via Local Connect. Tried again to pull and ran into the same “Local couldn’t load the file list” error.
  • I disconnected from WP Engine host and reconnected by again reentering the API credentials. This time it went through without issue.
  • Tried different approach of pulling the site to a new separate test site in Local. This succeeded.
  • Deleted this test site and went back to the original existing site and tried to pull. This time it succeeded.

So far it is working again with 8.1. Version 8.2 looks to use the new Okta login method which does not require me to enter the API creds. I’m wondering whether something is going wrong here with the SSH handling. In the logs, I see the “Error creating new SSH key” message which often associates with the failure to load the file list.

Your assistance is greatly appreciated!

Hi @amida

We do have a known bug impacting some WPE users with the new Okta login workflow on 8.2 and through your testing I think it’s likely you’re running into that. For now, as long as 8.1 is working normally you can stay on that version. Our Dev team is hard at work on a fix that we should have out soon to remedy this. Thank you for your patience and communication with us :slight_smile:

1 Like