Rsync: "Failed to create shell"


What issue or error are you experiencing?

When trying to push or pull from any of my connected WPEngine sites I get the error “Local couldn’t load the file list!”.

I checked the log file and it seems to be a non specific error with RSync. I tried manually SSHing into the server and I was authorized but received the same error. I tried restarting and resetting WPEngine API keys and SSH keys.

Thanks in advance!

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I attempt to push/pull from my Local instance.

System Details

  • Local Version: Version 8.1.0+6514

  • Operating System (OS) and OS version: macOS Sonoma 10.14 ARM64

Local Logs (713.8 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @nowmediaconnor!

We’ve been seeing some similar users among other users that we are currently investigating. I’m going to merge your post into another thread so we can keep communication in one place. Stay tuned!

A post was merged into an existing topic: Local couldn’t load the file list / Unable to pull or connect to WPE sites

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.