Local couldn't load the file list / Unable to pull or connect to WPE sites

Actually, in addition to disconnecting/reconnecting, I mean regenerating those API credentials that you use to connect to WPE as well. Details in the article above^

Keep us posted!

Yes, tried that too – regenerated new WPE API credentials.

Still, no dice.

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

OK, did all this – fully uninstalled, reinstalled, restarted, still not working:
local-logs.zip (1.2 MB)

Thank you for trying that @jhenrywaugh!

I’ll share this with the Devs but also will being sending you a message to gather more info.

Hi @jhenrywaugh

Our Devs narrowed down what they believe to be the root cause here and have released a Beta version of Local to try and see if it resolves the problem. Once we know this fix works we’ll roll out a stable release to follow! Can you give this a try and let us know if it does the trick?

I was having the same issue and can confirm that while Version 8.0.1+6490 for Intel MacOS does not work for me, Version 8.0.2+local-beta-6503 does.

1 Like

Glad to hear it @bradc! Thank you for coming by to let us know :green_heart:

Seems to be working (Local Beta 8.0.2), have connected & pulled from a couple of WPE sites.

1 Like

Thank you for confirming @jhenrywaugh! We’ve heard from several other WPE users that this is the case and will likely have a stable release out today with the fix. :green_heart:

I am having a weird issue. I had upgraded to the latest release as of today, 8.1.0, but when I tried to connect to a site to pull, I kept getting an error that it couldn’t get a list of files. I tried to go back to 8.0.2 official release, and it wasn’t working either. I was able to SSH in and I was able to get a list of the sites with the API key I had.

Oddly, I had to revert back to Version 8.0.1+6490 in order to connect and get a list of files.

I tried pulling down the beta as well and it doesn’t work either. When using anything above v8.0.1, it seems to give me the same errors in the logs:
{"class":"RsyncService","level":"warn","message":"Cannot access install mysite\r\nConnection to mysite.ssh.wpengine.net closed by remote host.\r\n","thread":"main","timestamp":"2023-11-13T22:45:47.217Z"}
{"class":"RsyncService","level":"warn","message":"rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]\nrsync error: error in rsync protocol data stream (code 12) at io.c(226) [Receiver=3.1.3]\n","thread":"main","timestamp":"2023-11-13T22:45:47.218Z"}

I am using an SSH key and a custom config that specifies the specific key for any ssh.wpengine.net host. If I SSH in using the same key and with the same install, I can connect just fine. I know with v8.0.2 there were some changes to ignore local config files for SSH, so not sure if this has anything to do with it.

Are you on MacOS Catalina by chance @rbaugh?

Hi, I am running version Version 8.0.2+local-beta-6503 but still can’t connect to WPE to pull a site. I am running OSX 14.1.1, here’s my log:
local-beta.log (13.0 KB)

Hi @diego2d

Can you download the latest release here:

And then reset your API credentials here:

If you’re still having problems after that please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

@Nick-B No I am running Monterey 12.6.

So is 8.0.1 still working for you? Or are you having issues no matter the version?

If you don’t mind, please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information and we can take a deeper look.

8.0.1+6490 is working for me, but upgrading to anything after this is causing me the problems.

local-logs.zip (916.9 KB)

Is this happening when you try to connect with any sites? Or just a specific site?

Are you able to access the sites already in your Local app okay if you update?

Are there any sites you could try connecting to that you’ve never synced before to see if they work?

This happens on all sites. I can’t seem to get a list from the server(s) on any site. This issue only starts when I upgrade past 8.0.1. Right now I am staying on 8.0.1 so I can do my work and be able to sync as needed.

I assume the logs had the records from when I had upgraded. If they didn’t, I can try and upgrade, run some tests, and provide the updated logs before I revert back.