Mac OS 15 - Rsync issues

What issue or error are you experiencing?

Since updating to Mac OS 15, receiving “Uh-oh! We ran into an issue when pulling from WP Engine.” when trying to push or pull files/db.


System Details

  • Local Version: Version 9.0.3+6684

  • Operating System (OS) and OS version: macOS 15.0 Beta (24A5264n)


Local Logs

local-logs.zip (858.5 KB)

I’ve tried a few things, just to get ahead of general troubleshooting:

  • Downgraded and tried 4 previous versions of Local, none worked.
  • Uninstalled Local entirely, following the knowledge base doc, and reinstalled.
  • Rebooted machine.
  • Updated/Upgraded Rsync. rsync 3.3.0
1 Like

Hi @kleinmaetschke

Can you try this?

  • Log out of your WPE account in Local
  • Quit Local
  • Disable API Access in your WPE account dashboard
  • Enable it again
  • Reopen Local and log back into your WPE account
  • Try again

Thanks, @Nick-B. Unfortunately, the issue appears to persist. I’ve attached newer logs, in case they provide any insight.

Additionally, I tried to sync “Selected Files” this go-round, and doesn’t display the file list, giving the error “Local couldn’t load the file list!”.

local-logs1.zip (866.5 KB)

As a workaround, are you able to download a backup and direct import that into Local?

Is there anything else unique about your connection? Are you on a work/office network? Do you use a VPN?

I’m able to do the backup and import for now. But that doesn’t help me easily push changes, of course.

Nothing unique about connection. Standard home internet connection. No VPN, no firewall.

Okay glad to hear the import works. It’s always worth testing that at least because sometimes if that errors out then it might point to a site level issue versus something wrong with the connection. I’m not seeing anything specific in your logs to point to a culprit yet. I’m checking with my team to see if anything stands out regarding the latest Mac update.

I appreciate you looking into it. I understand Mac OS betas likely fall outside your standard support scope. But I’m happy to test things out for you if it means I can find a solution and hopefully benefits your team preparing for the update as well.

1 Like

Appreciate your offer! I’ve raised this with the Devs who are looking into this but we don’t have a solution yet or a firm ETA on when any potential conflicts are addressed.

Is it possible at all to revert your update to see if functionality resumes as normal?

Not easily, unfortunately. Though I’m sure it would return normal functionality.

No worries we just wanted to throw that out there if it was a possibility to get you going in the meantime. For now you might have to rely on more manual migration methods for importing/exporting unless you have access to another machine.

I’m curious: What are the manual migration methods WP Engine recommends? I know how to backup the WPE site, export, and import locally. But what is the recommended method the other direction?

The easiest method would probably be doing a migration with WPE’s own migrate plugin:

Otherwise you could utilize more manual workflows like SSH or SFTP: