Local does not open on my computer (Ubuntu 16.04)

What issue or error are you experiencing?

—Hello I have just installed Local for Linux Ubuntu on my computer, downloaded the .deb file, clicked on install, but when I want to launch the program nothing happens, impossible to open the program…
I do not know what to do
Can you help me ?
Thanks in advance

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:

  • Operating System (OS) and OS version:

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @michelmougenot

This might be due to the age of your OS and it having reached its end of life. Are you able to create a site or can you not open the Local app at all?

You might have to go back on our releases page and use an older version of Local. You won’t be able to use the latest versions of PHP and so on until you’re able to update your OS but you could still use the app and most of the features:

Hi Nick-B, my version of Ubuntu is that of April 2016, I will try to install an old version of local thank you very much for your advice

1 Like

Hi Nick-B,
I tried to install a previous version (local-5.4.1-linux.deb), it works now, I can open the application, but I cannot create a site a window opens and I cannot create a site…
here is the content of the error message =
“Uh-oh! Unable to provision site.
Error: Error: listen EADDRNOTAVAIL: address not available ::1:10000
at Server.setupListenHandle [as _listen2] (net.js:1211:19)
at listenInCluster (net.js:1276:12)
at doListen (net.js:1415:7)
at processTicksAndRejections (internal/process/task_queues.js:77:11)”

Hi @michelmougenot

If you change your Router Mode to Localhost are you able to proceed? Preferences>Advanced>Router Mode>Localhost

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.