Local Community

Local Lightning PHP 8 "Open Site Shell" does not work on ZSH

Bug Summary

I previously made a bug report about “open site shell” not working on zsh for php 7.4.1, which was solved by the Local dev team. The same exact bug is present on php 8.0, and is likely an easy fix, given that it has been fixed in 7.4.1. Here is the original bug report (with details on resolution): Open Site Shell fails on zsh, works on bash, for some php versions (ubuntu/linux)

Steps to reproduce

On Linux (.deb version), with zsh as your shell, create a site with php 8, and try to use “open site shell”. It will fail. Then change your shell to bash, and repeat. It will succeed.

Environment Info

  • What Operating System are you using?
    PopOS / Ubuntu / Debian
  • What versions of site software (Nginx, Apache, PHP, MySQL) is used?
    PHP 8, with any server and db
  • What version of Local is installed?
    6.3.x and all previous versions (I have been experiencing this for more than a year and just bringing it up again in hopes it can get some attention)

This one should be an easy win for the dev team. Any chance we’ll have a look?

Hi @tlock,

Thanks for bumping this, and apologies that you’re running into the issue with PHP 8! I found the ticket from your last post in our ticketing system, so that gives me some more details too. Let me duplicate this for PHP 8 and get it front of the dev team.

I don’t have an ETA yet, but I’ll link this thread in our ticket so that we make sure to come back here as soon as it is being worked.

Thanks,
Austin

Fantastic, thanks for the update!

Just a friendly check-up, did this get into the queue?

Hi Austin, did we get this into the queue?

Hi @tlock - it is at the top of our backlog right now, but it has not been worked yet. We’re wrapping up some Blueprints and accessibility improvements to the Local app; once those are finished, this bug and our bug around untrusted SSL certs are the first two in.

Unfortunately, no ETA yet, but I haven’t forgotten about you - you’ll be the first to know when we’ve pulled it in!

1 Like

Thanks for the update!