Local not opening at all

Hi all,

I have three sites I’m currently developing and I hope I don’t lose them.

Local was working fine last week, it’s been asking me to update for a while now but I put it off, then all of a sudden I started getting stuck in the ‘starting local machine’ loop - so I decided to update Local.

Now it won’t start at all - clicking the shortcut, exe. etc. doesn’t do a thing.

I’ve tried updating VM Virtualbox to the latest version.
I’ve tried removing the virtual NIC in Virtualbox.
I’ve tried stopping the VM instance in Virtualbox, closing Virtualbox and restarting Local.

I haven’t yet tried uninstalling and reinstalling local. If I do this, what happens to my sites?


Hey @bpinnington,

Man, we certainly don’t like to see issues with Local not starting. It sounds like you might be running into an issue we learned about and fixed in 2.4.6 where a lingering process prevents Local from starting. That’s definitely our bad! :grimacing: Now this is going to sound silly to ask, but would try restarting Windows? If it is a process hanging around, this will hopefully get you far enough to start Local again and upgrade to the latest version so this troll of a bug doesn’t hurt you (or anyone else) ever again :sweat_smile:

Please let it know how it goes.

Hey @flycrum,

No go unfortunately.

Is it possible to download the update separately and install?