Local not opening under Windows 10 Pro Versão 22H2

Issue Summary

The location in windows 10 Versão 22H2 does not open, there is no sign of anything, I have already installed several versions of the location and the new one is the same problem, Installation without any error does not open anymore, it does not show anything, I have already installed it on the 2 users that I have and nothing both together and nothing tried everything. It was working normally, it stopped working when I created a new Windows user, it didn’t work either on the old user or on the new one.

One or two sentence summary of the issue.
The site does not give any sign that the installation was running normally.

  • Does this happen for all sites in Local, or just one in particular?
    The problem happens to all windows users

Describe the steps that others can take to replicate this issue. If you have screenshots that can help clarify what is happening, please include them!
local-lightning.log (1.9 KB)

System Details

Windows 10 Pro Versão 22H2 - 19045.3086

  • Which version of Local is being used?
    I started with the most current Local 7.0.1 and it didn’t work so I went back to another version that worked normally than Local 6.4.2 and after that I tested several and it didn’t work

  • What Operating System (OS) and OS version is being used?
    Windows 10 Pro

  • Attach the Local Log. See this Help Doc for instructions on how to do so:
    local-lightning.log (1.9 KB)
    This log is the one time I used it because it didn’t open anymore and didn’t even show a sign of life

Hi @RobsonDesigner

To clarify are you saying the Local App itself won’t open? Or are you not able to open the site or access the WP Admin?

That the application of the place does not open, It does not give any sign of life.

Do you have any antivirus, security, or firewall applications that could be blocking Local?

More details about troubleshooting this here: Router Mode

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

1: I don’t use antivirus and windows defender is disabled.

2: This problem is not mine, my local app does not even open or run the program, remembering that I tested the current version and older versions and nothing strange and that it was normal.

3: I don’t use xampp or mamp, I had xampp installed and I uninstalled it to see if it was the problem and nothing and xampp functioned normally, opened the normal app.

Hi @RobsonDesigner

I’ve been working with another Windows user on the thread below with a similar issue. Can you try the steps here to see if there are still any Port Conflicts occuring?

Can you also check this?

I checked the ports that everything is ok, There is nothing conflicting on ports 80 and not being used by another app, I installed xampp to check if it works, It worked fine without any problem I will attach a print of xampp.

I also tried the other step of the host file and deletion in the antivirus, and what has installed and windows defender is disabled more to guarantee the deletion

I did both steps and it didn’t work, there is no sign of life that the local app will open, very strange.
it worked normally, I just went to create another user who doesn’t want to open it and I installed xampp to see if it worked and it works normally

Have you used Local on this machine previously and it worked fine or was this your first time installing it and it never opened?

Do you happen to have another device you can install it on to see if it will load up?

Would you be able to send us a fresh Local Log? Since you can’t open the app you might have to search for the files manually and see if there is anything inside of your Router and Error logs.

I used it before and it works normally, which is strange, the only log it has is the one I already sent and found in the data roaming app, is there any other place you can see logs
local-lightning.log (4.2 KB)
local-lightning-verbose.log (50.2 KB)
I found these two log folders

I’m going to test it in a virtual machine, with VMware Workstation to see if it works

I installed a virtual machine with windows 10 with VMware Workstation and it worked normally from the local app

1 Like

Hi @RobsonDesigner -

Thank you for letting us know that this worked for you.

Do you need more support on this ticket?

Thank you!


Not working yet, @Nick-B Asked to stop testing on another machine it worked on a virtual machine not on my machine with my Windows the problem still persists local app does not open.

To use the app locally in a virtual machine with VMware Workstation, I found it a little slow because it is a virtual machine. I want to solve the problem of my physical machine, which is still having a problem with the app not opening.

Hi @RobsonDesigner

It’s tough to say what the hold-up still is. There is likely something, somewhere on the machine that is still blocking Local. With all security and developer applications shut down or removed, can you run through these steps to try and refresh?

  • If you were able to make any sites in Local in the past, save copies of the site files just in case

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

I finished all the steps and the problem of not opening the app from the location still persists
local-lightning.log (4.2 KB)

Hi @RobsonDesigner - Here is the error in your Local Log

{"thread":"main","errno":"ENOENT","code":"ENOENT","syscall":"spawnSync E:\\WINDOWS\\system32\\cmd.exe","path":"E:\\WINDOWS\\system32\\cmd.exe","spawnargs":["/d","/s","/c","\"ECHO %SystemRoot%\\System32\\drivers\\etc\\hosts\""],"error":{"errno":"ENOENT","code":"ENOENT","syscall":"spawnSync E:\\WINDOWS\\system32\\cmd.exe","path":"E:\\WINDOWS\\system32\\cmd.exe","spawnargs":["/d","/s","/c","\"ECHO %SystemRoot%\\System32\\drivers\\etc\\hosts\""],"error":{"errno":"ENOENT","code":"ENOENT","syscall":"spawnSync E:\\WINDOWS\\system32\\cmd.exe","path":"E:\\WINDOWS\\system32\\cmd.exe","spawnargs":["/d","/s","/c","\"ECHO %SystemRoot%\\System32\\drivers\\etc\\hosts\""],"error":{"errno":"ENOENT","code":"ENOENT","syscall":"spawnSync E:\\WINDOWS\\system32\\cmd.exe","path":"E:\\WINDOWS\\system32\\cmd.exe","spawnargs":["/d","/s","/c","\"ECHO %SystemRoot%\\System32\\drivers\\etc\\hosts\""],"error":{"errno":"ENOENT","code":"ENOENT","syscall":"spawnSync E:\\WINDOWS\\system32\\cmd.exe","path":"E:\\WINDOWS\\system32\\cmd.exe","spawnargs":["/d","/s","/c","\"ECHO %SystemRoot%\\System32\\drivers\\etc\\hosts\""],"error":"[Circular]","status":null,"signal":null,"output":null,"pid":0,"stdout":null,"stderr":null,"level":"error"},"status":null,"signal":null,"output":null,"pid":0,"stdout":null,"stderr":null,"level":"error"},"status":null,"signal":null,"output":null,"pid":0,"stdout":null,"stderr":null,"level":"error"},"status":null,"signal":null,"output":null,"pid":0,"stdout":null,"stderr":null,"level":"error"},"status":null,"signal":null,"output":null,"pid":0,"stdout":null,"stderr":null,"level":"error","stack":"Error: spawnSync E:\\WINDOWS\\system32\\cmd.exe ENOENT\n    at Object.spawnSync (internal/child_process.js:1041:20)\n    at spawnSync (child_process.js:620:24)\n    at Object.execSync (child_process.js:665:15)\n    at Object.execSync (electron/js2c/asar.js:696:23)\n    at Object.<anonymous> (%%appPath%%\\main\\env.js:1:1082)\n    at Module._compile (internal/modules/cjs/loader.js:880:30)\n    at Object.Module._extensions..js (internal/modules/cjs/loader.js:892:10)\n    at Module.load (internal/modules/cjs/loader.js:735:32)\n    at Module._load (internal/modules/cjs/loader.js:648:12)\n    at Module._load (electron/js2c/asar.js:717:26)","message":"spawnSync E:\\WINDOWS\\system32\\cmd.exe ENOENT","timestamp":"2023-06-21T04:37:06.665Z"}

I’ve tried just a general web search for this and it seems to come up often with Windows users. Usually a path doesn’t exist, is blocked in some way, or broken.

Hi, @Nick-B It worked, I managed to open the app from the place I will show you how I managed to solve it, I followed your line if I reason what you told me.

I took the cmd.exe file that was on the C:\Windows\System32 disk, made a copy and pasted it in the user that I installed the location following the same path of the local disk C:
I was able to open the app from the normal location

1 Like

Glad to hear it @RobsonDesigner! Thank you for coming back and sharing your findings and resolution. Happy Developing :green_heart:

I managed to open the app from the normal location, but it doesn’t open the browser with the wordpress application, it doesn’t even open wp-admin or the main page and I already configured the browser to be used in the preferences and nothing, I tested other browsers and the wp didn’t open -admin and not the main page.
Not even to connect my local user because it doesn’t open the local.
local-lightning.log (20.0 KB)

After your fix above have you done any restarts of Local or your machine?

Does changing your Router Mode make any difference? (Preferences>Advanced>Router Mode)

Following your steps by going to preferences and changing to localhost it worked, Then to test it I went back to site domains and it worked normally, But I have to go to the browser manually and write, The problem of not opening the browser still persists, I’ll show you the print of error that appeared in the browser, but I noticed that sometimes in the domains of the site, sometimes the main page did not work, but wp-admin worked normally, which is strange and I also noticed that when I put the ssl sertified, the wp-admin page did not work and the main page worked these two errors happens when the preference was in domains of the site, but at least it’s giving to create the applications without ssl certificate it’s normal sometimes the main page doesn’t work anymore the wp-admin works, I solve it restarting there return to normal,

Error that persists and I did not open the browser directly through the location to access my account, wp-admin and the main page
Local Navegador
And as if he didn’t find the installed browsers.
Is there any file from the location that I can manually go to tell where the browser executable is? I think that would solve the problem.
local-lightning.log (49.6 KB)