Local not working when connected to VPN

How do I resolve Local not working when I am logged into VPN (Cisco AnyConnect Secure Mobility Client)? Works great when I’m not logged in to VPN, but when I am ‘Site Can’t be reached’ displays in the browser.

I assume this has something to do with both Local/VPN trying to use the same port 80? If so, how do I go about changing that? Working remotely from a work computer, so somewhat limited on things I can change.

Thanks in advance for any guidance!

1 Like

Hi Chad,

Try following the instructions for macOS in this topic: Help! My Local site cannot establish a connection to WordPress.org

For more information, see the following:

Clay thanks for your response. To clarify, I’m running on Windows 7 64-bit. I looked at the suggestions in your first link that also included tips for Windows. I ran the commands it suggests but still run into the same issue. When I start Local it runs continuously and never connects. This is the error that keeps coming up:

On the 2nd link I’m not following what it’s suggesting to do? I’m not too familiar with VM’s or modifying them via the cmd, so I’m not sure what I need to change to fit it for my needs…

“A workaround is to manually force every VM to use the host’s resolver with “VBoxManage modifyvm “VM name” --natdnshostresolver1 on” or to modify the guest’s /etc/resolv.conf file with an external nameserver.”

Here’s a screenshot of my cmd after running the suggestions from both the first & second link you shared:

Hey,actually, it’s could happen, you either switch to OpenProtocol VPN like Zunescene or simply turn it off.

“turn it off” and “change provider” aren’t solutions

If anyone is having trouble with Local when using a VPN, please try the Local 2.3.1 pre-release.

Local 2.3.1 has a patched version of docker-machine and will also automatically enable the NAT DNS Host Resolver option on the VM if it’s not enabled.

I’ve had lots of problems with this today with latest versions.

If I use Tunnelblick (open VPN) I resolved the issue but using generic VPN app breaks and I get the regenerating machine cert issue on load ad infinitum problem.

Would be great to get this working with more VPNs.

UPDATE: Enable Local Network Sharing in your VPN prefs for VPN to work with Local.


This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.