SSL problem MacOS 13.4.1 (Ventura) & Local 7.0.2


Issue Summary

I’m having problem installing a SSL certificates automatically. I still get the error that says "We ran into an issue trusting the Local SSL certificate. See this screenshot: Error

At the moment, I have to manually go in keychain and change the settings to always trust. But I’d like it automatic!

I’m using MacOS 13.4.1 and Local 7.0.2, I do have another MacBook and it works fine there. I just don’t understand why it doesn’t work on this one?!

Troubleshooting Questions

  • Does this happen for all sites in Local, or just one in particular?
    It happens on all instances of local WP sites.

  • Are you able to create a new, plain WordPress site in Local and access it in a Browser?

  • Attach the Local Log. See this Help Doc for instructions on how to do so: (103.0 KB)

If anyone knows or has this problem, please share so that we can find out what we need to do. It would be nice to not “re-install” the whole OS for this minor issue. But rather finding the problem and fixing it!

Thank you!

Hi @webconsultant247

Have you been through our help doc here?

1 Like

Yes, that’s the only way that I’m able to make it work. But I know they said they fixed this issue. I’m wondering what could be the problem that I have this problem.

I’m seeing a lot of Port Conflicts in your log. Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

Here are some steps to help us identify and address this:

  • Stop all sites that are running in Local

  • Force quit Local

  • (If using Mac) Run the command lsof -nP -iTCP -sTCP:LISTEN

  • (If using Windows) Run the command netstat -ano

What you’ll be looking for here is to see when sites are stopped and Local is properly shut down if there are still programs running on ports 80 and 443. These may be conflicting with Local or the system may be reporting Local is still running.

Once you run that command you should see a list of listening ports. If you see a particular program making use of those ports, you can then kill that process by running sudo kill -9 XXX where XXX is the PID number of that process. (On Windows you will use taskkill /F /pid XXX where XXX is the PID number of that process)

After that, you should be able to retry. Keep us posted if you have any questions or continuing issues.

There are also some more details around this and other troubleshooting steps at this link if needed: Stopping Whatever Is Listening On Port 80.

1 Like

Thanks for the information. Yes, I’m using Xampp, but I completely turned it off (stopped) and this problem existed even before I install Xampp.

I went ahead and ran that command in my terminal. Here is a screenshot of the ports:

I don’t really see any 80 or 443 ports in there.

I don’t have this issue on my other MBP (older version, but same OS and everything). That’s what makes me wonder what has changed here.

In order to refresh here and start with a clean slate could you give the below troubleshooting steps a try?

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

Thanks for the instructions. I followed these and tried it, and the same red box popped up. But after I try to restart the site, the “trusted” icon shows. However, there is no SSL and it doesn’t even open the the site with https. I attached the logs as well.

Logs: (2.6 KB)

Does the same thing happen if you open it in a different browser? Firefox, Safari, etc?

Yes, same thing happens!

When I hover it says this message “Trust the certificate …”



MS Edge

I saw you mentioned this happens for all sites. Does that include if you create a new, blank site and access it? Or is it just for sites you have already been working on in Local?

After you trust, have you tried running any S/Rs to fix up insecure content?

When I deleted the application and reset everything, I created new ones, a couple of them. So it happens for all sites.

I tried, but I get the warning on my browser, which means the SSL cert is not trusted.

I checked with the team because I thought there had been some changes around this as well but the error or pop-up that you get in the Local app about running into an issue trusting the SSL is actually expected behavior at this time. We do still have a bug open for the “Open Site” button specifically not respecting https:// but it can be worked around by manually adding it in.

If you’ve trusted it in your keychain, you’ll still need to manually add https:// at the front of the URL in the browser and the site should load fine. Are you finding that works okay?

It will work if we add it to the keychain, and we stop/start the site. But it doesn’t work when we just click on Trust. And it works, without going to kechain on my other computer (other MBP) but not the one for my work.

And the two machines are the exact same OS version?

Yes indeed, one is MacBook Pro 2017 13.3" (the one that it works fine) and one is MacBook Pro 2020 13.3" (the one that doesn’t work).

Does your work machine have any additional security extensions, firewalls, programs, etc?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.