SSL not working on mac osx Local 2.4.2

I’m having trouble getting the SSL working on my Local.

I’m on Mac OSX 10.13. Local 2.4.2.

I pulled a site from my flywheel account into a new local site. The flywheel site has SSL installed (This finally worked after a number of failed attempts). On Local, I then ‘TRUSTED’ the SSL cert. It changes to TRUSTED. However, when I access the local website, the SSL doesn’t seem to work.

When I click on some of the links/ product links etc, it has a https:// link and says “The owner of timeless-tanjore-new-dev.local has configured their website improperly.”

I tried restarting the site; restarting Local, my computer; I even pulled the site into new local sites twice but it doesn’t help

Also as a side issue, the images are still linked with the flywheel live domain links in the local site code.

Did someone experience this? Please help.

From what support told me in the past, most sites that are cloned don’t include an SSL certificate because passing around a server’s key means that the security of the server could be compromised.

I encountered the same issue with SSL in the same environment (as far as I know), MAC OS X and Local 2.4.2, but coming from a different host. The Trust SSL feature has not worked for any of my installations, on any of the three browsers I tried (Chrome, FireFox, or Safari). WordPress installations are considered “insecure” by the browsers. I have also tried this on a PC with Windows 10 yielding the same results. They did mention that having an antivirus installed may prevent the certificate from being installed but that there may be other factors.

Here are other threads with similar issues noted:

Please see the screenshots attached. It would be great to hear back regarding this issue.