Local on ChromeOS Debian -> Missing library libexslt.so.0

Issue Summary

ChromeOS allows running a VM with Debian. The installation of Local is straightforward. When setting up a site, I run into an error, that a library is missing on my system.

Screenshot 2021-09-07 12.54.35 PM

When I install php through apt I don’t see this error. As /opt/Local/resources/extraResources/lightning-services/php-7.3.5+11/bin/linux/bin/php is a bash file I also tried executing it in the terminal. This yields the same

/opt/Local/resources/extraResources/lightning-services/php-7.3.5+11/bin/linux/bin/php-original: error while loading shared libraries: libexslt.so.0: cannot open shared object file: No such file or directory

Hopefully you can help me. Thanks!

Troubleshooting Questions

Happens every time when I create a new site. Or when I try to start a site I previously created with this error


  1. Install Local on ChromeOS
  2. Open it and create a new site
  3. see error

System Details

System: Version 92.0.4515.162 (Official Build) (64-bit)
Device: Acer Chromebook Spin 13 CP713-1WN597
Local Version: 6.1.2 Linux Deb
local-lightning.log (66.2 KB)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.