Local will not run anymore - Hyper-V conflict

Nothing. Local by Flywheel just does not work.

Every time I attempt to start it up, I am greeted with multiple dialogs:

I have tried completely uninstalling Local and VirtualBox using Revo Uninstaller to get rid of all registry references as well, and rebooted. This is the 3.3.0 version of Local, because I did not like the lack of features in version 5.

Upon a fresh installation, this train wreck is what greets me.

Please help me before I give up completely on Local and Flywheel in general.

Hi @Sturm,

Please ensure that Hyper-V is fully disabled. See https://www.poweronplatforms.com/enable-disable-hyper-v-windows-10-8/ for details on how to do so.

Sorry for the trouble!

Thank you for the rapid response, @clay.

Looks pretty disabled to me.
(As a side note, isn’t Hyper-V a “good thing” to have? Why must it be disabled for Local?)

Hey @Sturm, because Local 3.x uses a virtualization through VirtualBox, and VB is incompatible with Hyper-V, Hyper-V needs to be completely disabled. Since two of the errors there mention Hyper-V, it is curious that your Windows Features show that it is disabled. If you unchecked anything, make sure to reboot.

Aside from that, see if you can open up VirtualBox on its own (it’s a separate application, though it is a program that Local 3.x is dependent on).

Yes, have rebooted this PC multiple times yesterday during the uninstall/reinstall procedure. All the while, Hyper-V was disabled.

VirtualBox does open up on its own:

But wants me to upgrade.

And when I attempt to run the VM from it:

bcdedit /set hypervisorlaunchtype off

I have tried everything I could Google to get this working. So many solutions I found simply do not work for me.

  • A VirtualBox forum post suggests turning off the three main virtualization settings built-in to Windows. All three were already unchecked for me.
  • A Spiceworks post lists a few command-line sequences to run in both CMD and PowerShell. Tried these (and it took a long time to run them) without success.
  • An answer on StackOverflow says to try just enabling Hyper-V, rebooting, diabling Hyper-V, then rebooting again. Didn’t help.
  • Another answer on that same SO post suggests running a bcdedit command if the main bcdedit response shows that hypervisorlaunchtype was set to on or auto. Mine never showed up, so I initially disregarded this answer.
  • A GitHub post recommended I disable Secure Boot in the BIOS/UEFI. I felt that would be going too far, so I didn’t even bother trying it.

In the end, as a Hail Mary, I tried the bcdedit command suggested in the fourth link in the above list even though hypervisorlaunchtype didn’t appear at all when I ran bcdedit by itself. After running

bcdedit /set hypervisorlaunchtype off

and making sure that it was reported as such:

I rebooted and tried starting up Local by Flywheel. It takes a good 20–30 seconds now to start up the local machine, but at least I no longer get the errors and I can, indeed, create some WordPress test sites.

Perhaps this information should be made accessible to others who are also having this issue and for whom the typical fixes don’t work? I’ve seen it reported in many places.

1 Like