Local won't start (Mac) and I'm not using Port 80

Hello community!

I’ve been searching the web looking for troubleshooting help when Local will not start the router (I am getting the “Heads-up! Local’s router is having trouble starting” error). The only advice I can find is to make sure no app is using Port 80. I purchased an app for Mac called PortsMonitor (also used terminal) just to make sure, and I’m definitely not using Port 80. Does anyone have any other ideas for what to do to get Local working with Site Domains router mode? I would really prefer not to switch to localhost mode because it doesn’t support HTTPS or live links.

Many thanks.

Local Version 7.0.2+6395

macOS Catalina Version 10.15.7

local-details.json (702 Bytes)
local-lightning.log (100.2 KB)

Hi @ellanyze

Are you running other developer applications simultaneously? Apps like MAMP, XAMPP, or Docker for example.

Do you have any antivirus, security, or firewall applications that could be blocking Local?

Here are some further steps you could take to investigate a Port Conflict:

  • (If using Mac) Run the command lsof -nP -iTCP -sTCP:LISTEN

What you’ll be looking for here is to see when Local is properly shut down if there are still programs running on ports 80 and 443. These may be conflicting with Local or the system may be reporting Local is still running.

Once you run that command you should see a list of listening ports. If you see a particular program making use of those ports, you can then kill that process by running sudo kill -9 XXX where XXX is the PID number of that process.

After that, you should be able to retry.

Hi Nick,

Thanks so much for your reply. I do have MAMP on my computer but it’s currently quit.

I ran your command in Terminal and saw a bunch of ports listed there but none of them were 80 or 443.

I found I had a malware app installed on my computer (although it was not running scans) but I uninstalled it anyway. MalwareBytes it was called.

Here is the error I’m now getting (attached screenshot) - does this help?

I am feeling at a loss of what else to try.

I have a bunch of client sites at WP Engine and would really like to be able to test to see if they will all work OK with the MySQL 8 upgrade in Oct (which is why I am trying to get this setup).

Many thanks again for your help.

After quitting MAMP and removing MalwareBytes did you reboot your machine? If not you might want to try a full restart.

Do you have any sites in Local already? Or were you just getting started with it? If you’re still having trouble we might try a full re-install next.

I did reboot my machine, that unfortunately did not solve it.
I’m also currently installing Local on my MacBook to see if it works on a different computer.
I’m currently deleting Local on my iMac and reinstalling to see if this helps.

When I open Local (after re-downloading/opening) it remembers my connection to WP Engine and my sites already show up. Is this OK or should I have used an un-installer of some sort instead?

I’m still getting the same error, but maybe I didn’t uninstall correctly?

In order to refresh and start with a clean slate I would run through these steps:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer with the steps in this article

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

Thank you, I have followed those steps. When I log into Local within the Local desktop app and begin pulling one of my WP Engine sites in (via the tutorial on WP Engine’s site) I’m already seeing errors at the top. Should I continue with pulling the site in, or try something else?

I had also turned off my Firewall in my computer’s System Preferences.

I will send the log file once the site is pulled in!

I installed Local on my MacBook. When I try to pull in one of my sites from WP Engine it’s giving me the error “Missing hosts entry. This site may be inaccessible.” Do you know what I can do about this?

I’m getting a different error on my MacBook now:

I, unfortunately, couldn’t get Local to work on my MacBook. I ran into errors when trying to pull in my site from WPE, and so when the site was there it said it couldn’t find the database either and when viewing the site it says 502 Erro bad gateway…

Hi @ellanyze

Are there any special characters in your username? That could be an issue in regards to your latest warning screenshot.

Missing Hosts Entry means Local couldn’t update the hosts file. You should be getting a password prompt to allow that and if that isn’t going through or isn’t coming up at all there might still be a security feature hampering things.

I am getting a similar error, it occurs when I try and start some sites, but not all, very odd, the issue started after the latest update to Local.

I thought I found a pattern, it seemed to occur on the sites configured to use PHP 8.1.9, however, I cannot change back to 7.4.1 asi it won’t start the necessary services because of the error in the screenshot.

Sites that are currently running PHP 7.4.1 most seem to start, but not all, so I will do more digging tomorrow

@kkramer2195 Did you try downgrading your Local version to what it was previously to see if that resolves the issue?

Also what OS are you on?

I’m on latest Mac OS, I’ll try downgrade later today if local. Thanks!

1 Like

Went back two Local versions, same thing on just some sites, the same no matter what version of Local I run…very odd…can anyone let me know how to check if MySQL is running for the sites? The thing I find odd is how can MySQL be running one site but not another when I click start site?

Error: Command failed: /Applications/Local.app/Contents/Resources/extraResources/lightning-services/mysql-8.0.16+6/bin/darwin/bin/mysqladmin ping
mysqladmin: connect to server at ‘localhost’ failed
error: ‘Can’t connect to local MySQL server through socket ‘/Users/kenkramer/Library/Application Support/Local/run/0h56OpkmU/mysql/mysqld.sock’ (61)’

Check that mysqld is running and that the socket: ‘/Users/kenkramer/Library/Application Support/Local/run/0h56OpkmU/mysql/mysqld.sock’ exists!

at ChildProcess.exithandler (node:child_process:407:12)
at ChildProcess.emit (node:events:527:28)
at maybeClose (node:internal/child_process:1092:16)
at ChildProcess._handle.onexit (node:internal/child_process:302:5)