Local wp no longer using connect to connect to wp engine platform

What issue or error are you experiencing?

Was working in last version. Updated now can no longer connect to wp engine account. Opens browser… and just gets stuck. No error, just nothing happens. Tried to uninstall and reinstall, still the same thing. Tried different browsers. Same thing.
Version 8.3.2 666

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version:
    Version 8.3.2 666
  • Operating System (OS) and OS version:
    Windows 11 Pro

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Thanks for the report, @TheDeann.

Please could you check for any security rules or software that could block access to Local’s login services? Here’s a thread including a list of those services that Local on Windows needs access to.

Once you’ve confirmed no services are blocked, it would be worth checking the troubleshooting steps here.

If neither of those things help, please could you share your Local logs?