Uh-oh! We ran into an issue when pulling from WP Engine

What issue or error are you experiencing?

I get this error when pulling any of the sites I have on WPE
Uh-oh! We ran into an issue when pulling from WP Engine
I tried a vpn and without a vpn
any ideas ?

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

System Details

  • Local Version:
    Latest, I reinstalled it as well to see if that helped but no…

  • Operating System (OS) and OS version:
    Mac OSX Ventura

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-logs.zip (299.0 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Condensed

Have you tried resetting your API credentials yet?

Is it happening with any site or just one specific site?

Good thought, but I just setup the api connection today so I doubt that’s it, I could try it again just to triple check. it is happening on all sites…

Are you using a VPN or an office network? If it’s happening across all sites it might be due to a network connectivity issue. If you’re using a VPN you could try toggling it off. If you’re using an office network there might be a built in firewall that’s throttling connections. If you’re able to you could also try connecting to a different network or use something like an LTE Hotspot to narrow down if it’s your current connection that’s the issue.

I am not using a VPN, I tried enabling my vpn because I read on a forum post that that might help but it didn’t work. Also just tried using my phone’s hotspot but still go the same error. Any other things I could try? I’ll try re-doing the API credentials but I don’t think that’s it, any other suggestions are greatly appreciated!

also not sure if this is helpful, but when I try to go to the site after getting the error it give me a 403 forbidden nginx error

Are you talking about when you go to the live site on WPE you get a 403?

As a workaround are you able to download a backup and direct import into Local?

I’ll try the manual import to see if that works. The 403 is when I click ‘visit site’ in local to see the local site. But I guess it would make sense that I would not be able to access it, since it never pulled properly…

To that point, are you able to create a new, blank site in Local and access that okay? That would rule out anything else “local” within your machine causing an interruption.

Before doing the manual import I tried changing the API key, I know that was the first thing you mentioned, but I really didn’t think it would work since I had just generated the key. Well… it worked. I am now experiencing another problem, but I’ll open another separate thread about that. Thanks for the help Nick!


Glad to hear things are working again @Condensed! If you have any other questions or concerns don’t hesitate to reach back out. We are always happy to help!

1 Like