Mailpit is not intercepting email messages (Windows)

What issue or error are you experiencing?

I used to be able to intercept email messages with Mailhog w/ this same dev site.

After the switch to Mailpit, I can successfully open the Mailpit UI at http://localhost:10030/, but it never updates to show any intercepted email messages.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I’ve tested with Gravity Forms submissions => Admin notifications.

I’ve also tried creating test WP users and telling WordPress to ‘notify the user’.

I found another thread that advised closing Local, removing the “mailpit-1.12.1+0” folder from “C:\Users<username>\AppData\Roaming\Local\lightning-services” and letting Local recreate that folder upon restarting. … Tried that w/o a change in behavior.


System Details

  • Local Version: 8.3.1+6650

  • Operating System (OS) and OS version: Windows 10 22H2 (19045.3930)


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi, @bishless, and thanks for this report.

Are you using Apache?

There’s a known issue with Mailpit and Apache under Windows at the moment that prevents mail delivery. The workaround is to switch the site to nginx while we investigate.

If instead you’re using nginx, please could you share Local’s logs?

3 Likes

Sure enough, the site was using Apache.

By switching to nginx it seems Mailpit is now functioning. Thanks for the recommendation!

2 Likes

@nickc Is there somewhere I can subscribe for updates on this issue? Because switching to nginx isn’t an option for a certain project for me…

@richardkorthuis Thanks for letting us know. I’ve made a note to post here when this is fixed.

We’ll also add an entry to the changelog in the release that resolves it. Changelogs first appear in the beta channel and then on the releases page for full releases.

1 Like