Missing hosts entry problem on Windows 10

I think I will need some help with this. I still can’t resolve problems mentioned in this post link to my previous post

As I explained in my previous post I have a problem with a warning that says “Warning! Missing hosts entry. This site may be inaccessible.” and after I click on fix it button I can see the following error pop-ups:

and after I click OK:

From other topics I know that BitDefender can cause some problems (preventing hosts file from being updated as I understand?) I’ve got BitDefender Internet Security 2018 so I followed advices from some other topic and disabled option in BitDefenders advanced settings that manages scanning of hosts file.

However this didn’t work in my case. I even destroyed virtual machine created by flywheel and then reinstalled Local once again in a hope that fresh start would help but still the same error about “node-windows.exe” and hosts file.

In a case it would be helpful my hosts file contains of nothing more than this (it’s fresh windows 10 installation, so I think it’s what it contains by default):

I really run out of ideas how to fix it so I would greatly appreciate any assistance or ideas what can be the root of this errors.

some additional information:

Local by Flywheel version: 2.1.1 for Windows
most recent log file: local-by-flywheel.log (136.6 KB)

Hi @paweltar,

Sorry for the trouble!

The next update should resolve this. In the meantime you can manually add the lines to the /etc/hosts file. You can find the IP needed by going to the “Database” tab and looking at the “Remote Host” value.

Hi Clay I’m Don. I have the exact same issue…however, I cannot click the FIX button…mine is inaccessible. I have no antivirus software running or a firewall or windows defender…cannot figure out WHY this is happening to me and many other here in the forums. May I ask WHEN the next update and fix for this will be available? thanks


Local by Flywheel Latest Version Downloaded and installed 2 Days ago for Windows 10
Most resent Log File local-by-flywheel.log (29.9 KB)

Hi Don,

Thanks for the log!

So, the fix it button is visible to you but clicking it does nothing?

Thank you @clay - it works, I can see my site as well as the admin panel and can log in normally. There are still beforementioned errors and warning but most important - it works. By the way - really great software, I’m going to spend some time to use it from now and know it better - I’m looking forward for the next update for Windows, but until then I will just manually edit etc/hosts

Exactly Clay…but more importantly…The error message that everyone else is getting…and I cannot access my local host created website…because of the error and the non clickable button.

IS there any news Clay or a fix for this issue. I’d really like to get started using Local By Flywheel…but cannot because of the host issue error message. Thanks



Based off of the errors, it looks like your computer might be missing the hosts file.

Can you verify that C:\Windows\System32\drivers\etc\hosts exists? If it doesn’t, see https://support.microsoft.com/en-us/help/972034/how-to-reset-the-hosts-file-back-to-the-default for more information.

Thanks Clay for the reply and answer…I’ll go check now. I remember the folder being empty when I checked the first night I installed Local by Flywheel. However, I’m going to just go to microsoft and RESET it as you recommend. I’ll send an update when I have reset it…and tried to start the test website I created with no errors about the host file missing. Thanks again.

Did exactly what you mentioned Clay…and now when I start Local…it just hangs gets stuck on the LOADING screen…but never loads.

Also I didn’t have a “hosts” file…So I created one…I did have a lmhosts.SAM file…So I changed that to lmhosts, then I renamed it after to imhosts.old (This is what windows recommended)

This is when the local load stared hanging at the startup screen.

Ik then went to ad “hosts” file…so I created that…and the imhosts file now is imhosts.old…and the startup screen still hangs and gets stuck loading…yet NEVER Loads.

Hey Clay…Thanks for the solution that led me in the right direction…but I went a bit further. I did what you told me…as you can see my message from yesterday…I got a NEW Issue…while the 1st issue had not yet been solved. Fast Forward to today…I read this post about NOT Working IN Windows 10…and I followed the steps there…and BAM!!! I went to reload Local By Flywheel…and a windows 10 message notified me that local by flywheel was trying to install or REDIRECT to the 'hosts" file you had me create from the Microsoft link…Well IT WORKED!!! BUT NOT WITHOUT ADDING THE FIRST STEP THEN THE STEPS FROM TODAY MESSAGE BY ANOTHER USER.

After I did what you suggested in your last message and link…and by adding whats in the link above…this solved my problem…and I was able to get the test site working…and the cannot Find Hosts file error…WENT AWAY!!! THIS WORKS 100%!!! Let everyone else know who are having the same issue. Thanks again Clay.


Hi Don,

Glad you got it working!

Just to clarify, you had to go to VirtualBox and delete the local-by-flywheel VM for this issue to go away?

I have the same question as @clay because as I understand you were able to fix those exact errors that I mentioned in my post and you are on Windows 10, right?

What I’ve done before was:

  1. Deleting totally the local-by-flywheel VM inside VirtualBox
  2. Reinstalling Local
  3. I’ve edited hosts file on my computer manually (it existed before on my windows, but Local just wasn’t able to edit this file automatically)

This way I was able to see working site in my browser, however, nothing changed when it comes to warnings and errors being visible on my screenshots above - I still see them.

So did you do anything more except those steps I mentioned? Would be great if I would get rid of those errors too.

Yes, thats exactly what I did. Now there’s another issue. Some error about a Container…One minute everything was working…I left my computer with local running for about 2 hours…then came back…and the test site wouldn’t start. I did the remove local fix…and I got the missing or no container error. SMH…When is an update coming that eliminates ALL of the issue I and other are having on Windows 10??? Thanks clay.

@paweltar Hi, I first created a NEW host file as Clay mentioned to do with my issue. Then I saw a new post complaining that this issue is happening on Windows 10…and the fix doesn’t work…So I followed what they did…In my post above screenshot…and What do you know…I restarted Local…and it worked. Windows told me that local was trying to access and point to the new hosts file that I created…after it located it and linked…I was able to access the test website I created. Now today…Something very different is happening. Don’t know if it’s a internet connection issue…but when trying to START the test website…it just hangs…sometimes it gives an error about missing montainer…other times…,.it loads and loads…but never completes…and goes to the website…SMH. Clay We Need An UPDATE Brother. I know you’re working hard already. Please send any new info about a fix on Windows 10 about these issues. Thanks brother

Please create a new thread so we can better track the other issue you’re running into. When creating the thread, please include the local-by-flywheel.log file after attempting to start the site in Local. Here are the instructions for retrieving that file: How do I retrieve Local's log file? - FAQ - Local Community

Hi Clay, I just got your message brother. I found a solution. I had to “completely” delete Every aspect of the Local By Flywheel Instal including the VirtualBox installation from my Windows Desktop computer. After a few attempts to just delete the software install…I realized that The Folders and Files were “STILL DISPLAYING” in multiple locations on my computer. It wasn’t enough to just delete the app…and restart my computer…because every time I did that…I’d find the SAME installed/created Website folder…no matter how many times I deleted the app. So I got smart, and deleted EVERY Association of the previous version of the app.

I then downloaded the Latest update from yesterday’s release…and it installed with NO ISSUES!!! THANKS CLAY, you and the guys and gals at LBF ROCK!!! Please pass this along…I’ll upload my current log anyways. Thanks Now I can start creating and testing some of these client websites and my own personal business ideas and websites on Local By Flywheel.

One more question: Is there a way to increase the file size upload limit…seems like there’s a set limit…because the BE theme wouldn’t upload. I’'d like to set it to the highest allowable upload limit. Thanks

Blessings-Donlocal-by-flywheel.log (25.2 KB)

Glad you got it working!

Do you have a screenshot of the error you’re running into when uploading the theme?

Also, one other thing you can do in the meantime is to extract the theme into the site’s app/public/wp-content/themes directory using the regular file browser on Windows. You can easily get to the site’s folder by clicking on the circled arrow by the site path underneath the site title in Local.

I’ll take the screenshot now…BRB. Thanks Clay.

Here’s the screenshot…and a video of the selection process of the plugin

Can’t upload the 20 sec video of the selection of the theme from my desktop…files too large in zip format. So the screenshot should be enough. It shows the error message. Thanks Clay.