Missing openssl.cnf file

I am trying to connect MainWP to my local sites and have run into the openssl.cnf file issue. The php info says it should be here /usr/local/etc/openssl@1.1/openssl.cnf but the etc folder doesn’t exist. I’ve tried /usr/lib/ssl/openssl.cnf and I’ve also tried adding an openssl.cnf file generated by SEOPress plugin into the folder I am pointing MainWP to.

How to I fix this issue please?

Hi @jenefer.

What OS are you using?

This previous thread on the subject might be helpful to you:

I’d been through that thread and it didn’t work. What I have found to work is connecting the sites via http instead of https even though they work as https. Not ideal but better than using MAMP (which works using https)

My OS is macOS Ventura 13.3.1

1 Like

Hi @jenefer

I’m glad you were at least able to find a workaround.

So at this time, the problem is that the sites are functional and work with MainWP but are still showing insecure in the browser?

The sites are secure in the browser but I have to link them to mainwp using http. If I run the local sites using mamp I can connect them with https so it seems it’s an issue with local

Hi @jenefer

Thank you for the clarification!

Can you let me know what OS you’re using and what Local Version you’re on?

1 Like

Hi @Nick-B

OS is venture 13.4 and local version is 6.7.2+6375

Hi @jenefer

What other paths have you tried to connect with? Have you used /usr/lib/ssl/openssl.cnf or /etc/ssl/openssl.cnf?

What PHP version are you using?

If you go to WP > Settings > MainWP Child > Settings page is the Security ID button checked or unchecked?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.