New install on Windows 10 stuck on installing WP

What issue or error are you experiencing?

Adding 1st site - stuck on loading “Wordpress Version” for ever

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Install on Windows 10 (?)


System Details

  • Local Version:
    Version 8.3.2+6660

  • Operating System (OS) and OS version:
    Windows 10


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Log stops with:
{“class”:“WordPressInstaller”,“download”:“https://downloads.wordpress.org/release/wordpress-6.4.3.tar.gz",“level”:“info”,“message”:"Latest version info”,“thread”:“main”,“timestamp”:“2024-03-30T18:08:10.420Z”,“version”:“6.4.3”}


Workaround:
Go to: Preferences; Advanced; Change the Router Mode to “Local Host” in the drop down; press the Apply Button; then try adding a new site. This worked for me.

Workaround found in a topic called Adding 1st site - stuck on loading “Wordpress Version” for long long time from 2020

Hi @erikvw

If Localhost is working it means you likely having something blocking ports Local is trying to use on Site Domains mode.

Do you have any antivirus, security, or firewall applications that could be blocking Local? It looks like from the log it might be having trouble connecting.

More details about troubleshooting this here: Router Mode

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.