Version 8.1.0+6514 - cant create new site

What issue or error are you experiencing?

after update local, i can’t create a new site with win10 / local 8.1.0 / custom / php8.2.10 / apach 2.4.43 / MySQL 8.0.16
its the same issue on local / prefered

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Local block on Adding WordPress without any files in folder public/.

System Details

  • Local Version:
    Version 8.1.0+6514
  • Operating System (OS) and OS version:
    Windows 10

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)
local-lightning.log (245.8 KB)
local-lightning-verbose.log (309.1 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Taz91

If you change your Router Mode to Localhost are you able to proceed? Preferences>Advanced>Router Mode>Localhost

Hi et thank you @Nick-B
Sorry, but i am allready in localhost router mode. i try in site domains. thank you.
with site domains it’s the same issue. blocking in “Adding Wordpress”

Was Local working for you before this version? Or was this your first attempt?

Do you have any antivirus, security, or firewall applications that could be blocking Local?

before it’s ok with 8.0.1
for antivirus i think not, i tried to up wp 6.4 on another site and it’s ok, and i see data on network when i try to create no data are load when adding WordPress…

Can you downgrade to 8.0 to get things working normally again?

with 8.0.1 it’s not ok actually.
i have désactivate firewal and betdefender, it’s ko.
it’s ko with run in administror status
i try to retstart my pc.

1 Like

after restart pc and all firewall desactived, always blocked in Adding WordPess
local-lightning.log (267.5 KB)
local-lightning-verbose.log (726.4 KB)

i tried with 8.0.0 it’s same issue.
i don’t known how resolve, i am sorry.

Hi @Taz91

This piece of your Local Log points to the issue:

{"class":"WordPressInstaller","download":"","level":"info","message":"Latest version info","thread":"main","timestamp":"2023-11-09T15:01:24.129Z","version":"6.4.1"}
> {"level":"error","message":"Unexpected end of data","stack":"Error: Unexpected end of data\n at Extract._final (%%appPath%%\\node_modules\\tar-stream\\extract.js:253:42)\n at callFinal (%%appPath%%\\node_modules\\tar-stream\\node_modules\\readable-stream\\lib\\_stream_writable.js:590:10)\n at process.processTicksAndRejections (node:internal/process/task_queues:82:21)","thread":"main","timestamp":"2023-11-09T15:01:24.147Z"}
> {"class":"Process","level":"info","message":"Killing process","pid":25644,"process":"

It looks like your computer goes to download that file at that URL… and for some reason, somewhere in the middle, it errors out. It could still be a Firewall or security blocker, or it could be some issue with your network connection. If you’re sure there isn’t any security conflict, you could try a different connection if you’re able to relocate to see if that creates any change.


I have the same problem on Windows 11.

Since I updated local I can’t install a new site. I’m stuck at the “Adding WordPress” step.

I tested the first time with the version of php8.2.10/nginx/MySQL 8.0.16 it did not work as you can see in the screenshot. So I left the preferred settings with php8.1.23 but I still have the same problem. I can’t install a new site.

However, my existing sites work with both versions of PHP.

Here are the screenshots of my manipulations.

Desactivate the security (Firewall and antivirus)

Create site :


PHP 8.1.23/nginx/MySQL 8.0.16

Add site

Provisioning Services ==> OK

Starting up Site Services ==> OK

Adding WordPress ==> KO

Folders :

Public and logs > php are empty

Nginx have an error file with 0Ko

Thank you for your help.

Hi Nick-B,
this morning I tried to download the file with my browser with the command:
the download was done in 2 seconds.

I just checked when I created my last sites. I created 3 sites on Nov 8 before updating my localwp.

I don’t see what could be blocking my side. But I definitely don’t know how to do it.
Really thank you for your help. I exported all of my test sites. If I have to go through wamp again they will be ready.

Did you try changing your Router Mode to Localhost to see if that works?

Preferences>Advanced>Router Mode

All of your Local Logs are empty as well?

In order to refresh here and start with a clean slate you could try the steps here:

  • Export any sites that you have on Local and save them to a folder somewhere on your computer.

  • Fully uninstall Local from your computer.

  • Install the latest version of Local on this link.

  • Once installed, please restart the computer.

  • When the computer is restarted and turned on, close any applications that automatically run in the background (AntiVirus, Firewall, and other Developer applications included).

  • Check and see if the issue still persists. If so, please provide us with an updated log and we can see if the errors are the same or different. Retrieving Local’s Log File

Keep us posted and we’d be happy to help further!

I just tried what you recommend. I switched the router mode from Site domains to localhost (although it does not support https. I always installed my others sites with the Site domains mode of router and it worked).
I carried out a site installation but it still glitches. I have the same result:
I’m stuck at the “Adding WordPress” step and the public and log files are still empty.
Thank you

I tried router site domains and localhost. It’s still in error.
local-lightning.log (377.4 KB)
local-lightning-verbose.log (386.4 KB)

Did you run through the steps here?

@FGC You could run through those as well to try and refresh. If your logs are empty then something is likely still blocking Local on your machine.

Okay I’ll uninstall everything and come back here. Really nice for your help.

Hi Nick-B,
In the end, I exported everything, deleted everything, uninstalled everything. Then re-installed the latest version. I tried to create a site, the first time it didn’t go through due to the firewall. Once the exception was added, I re-tested the site creation… and there, great, it’s all good. A really big thank you for all the time you gave me.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.