New Site Not Secure

Issue Summary

Hey guys, just downloaded Local and created a brand new WP installation. No content has been added whatsoever.

  • When opening the site from within the Dashboard, I’m getting the “Not Secure” warning in all browsers…


  • I followed the advice to “trust” the site in Local Admin and edited the Keychain information for the specific certificate to “Always Trust”

  • Installed BSR and ran it over the DB to change any instances of http to https

  • Restarted the system, cleared browser cache and still getting the warning

System Details

  • Local v7.01+6387
  • macOS Ventura

NOTE: - If I edit the URL in the browser to add https:// in front of the domain, it’s fine???

How do I fix this?


Hi @krackedkreative -

Are you trying to open the site from the Local app via the Open site link?

I would expect if you ran BSR it should automatically redirect http:// to https://.

Since it works when you manually change the URL to https:// it sounds like the SSL is working, unless I’m missing something?


Hey Sam, yes visiting the site by pressing the “Open Site” button from the App dashboard opens the HTTP URL for the site every time!

If I type the URL manually using HTTPS it’s fine.

Surely that’s not Local’s default behaviour?


I wonder if there is still some caching on your network.

There are some different things to try and get around network caching. Restarting your device, restarting the network router/modem, using a VPN connection, or adding a cache-breaking path to the end of the site that’s cached. Adding /? followed by any 4 random characters (/?1234 for example) will sometimes break the cache as well.

Hey Nick, I just changed the Local Settings to use Firefox (first) and then Safari. I haven’t previously opened the site with either! Both browsers opened the HTTP url for the site. I thought maybe it was a Chrome thing as it can exhibit some stubborn caching traits, but it’s obviously not limited to Chrome.

  1. So I reset the settings back to using Chrome; quit Local, deleted all of the cookies and site data for the site URL and quit Chrome. Restarted my MacBook, started Local and clicked Open Site; same behaviour!!
  1. I have a Chrome Extension to show me any redirect paths for sites visited and there are no redirects for this URL; Local is opening the HTTP version of the site every time.

  2. I searched the DB again for any instances of HTTP: and pingomatic is the only one.

  3. I’ve performed countless HTTP to HTTPS migrations over the years and often use HTTPS Checker to provide a visual confirmation of a site’s status post-migration. I dropped the SiteURL into the App =>

Screenshot 2023-06-26 at 5.33.21 pm.png

What I don’t understand is what URL is Local “calling” when I use the Open Site button below and where is it coming from??

When I click the WP Admin button, Local opens https://freelancerpro.local/wp-admin/ No problems…

Screenshot 2023-06-26 at 5.06.34 pm.png

Kind regards,


Hi there @krackedkreative -

Hmm, that is pretty odd behavior. Regardless of how Local opens the site http:// or https:// I would expect that you’d be redirected to https:// anyway.

If you create a brand new Local site and set up SSL, trust, etc does it work?


Hello Sam, I did actually try this just after I emailed my last response, but thought I’d try it again, just for the sake of it

Created a brand new site with the unique domain (to my browsers anyway) dummysite.local using the default “preferred” environment.

Screenshot 2023-06-28 at 4.34.43 pm.png

Clicked on “trust” and got the usual warning message that there is a problem trusting the certificate.

So I open “Keychain Access”, select the domain…

Screenshot 2023-06-28 at 4.54.47 pm.png

Set the certificate to “Always Trust” and exit “Keychain Access”.

Quit Local and restart…

Select the site and I can see that the certificate is now trusted.

Screenshot 2023-06-28 at 4.38.21 pm.png

Click “Open Site”…

Screenshot 2023-06-28 at 4.39.31 pm.png

What am I missing?

PS: Probably unrelated, but I still have Desktop Server installed, and it’s recently stopped working after installing Local… Can no longer access Localhost!
I was hoping to export my sites from DS and import them into Local, but one issue at a time… :v:

Screenshot 2023-06-28 at 5.02.45 pm.png

Kind regards,

Paul Carter

Hi @krackedkreative -

What about in other browsers (not Google Chrome)?

Did you do Step 4 here?

Also, I don’t think I see it above - can you please upload your Local Log? Here’s how to do that: Retrieving Local’s Log File - Local


Hello Sam,

  1. I have tried changing the default browser settings in Local and opening the sites in Safari and Firefox => Same Result! Neither browser had opened the site previously so there was no stored cookies / site data / cache.

  2. Yes, I had already discovered that the one-click “Trust” button does not work. I gather that due to the issues with newer Mac OS not allowing Local to trust SSL certificates automatically, that I have to manually trust the certificate for every site via “Key Chain Access”…

a) I have done this for both sites

b) I have changed the Site URLs and Home URLs to https://
c) I have run a search/replace over the DBs and replaced all instances of http with https

Below are the details for the two sites I have installed - Local is clearly showing that the certificates are both “trusted" (3.23 KB)

Hey Sam, any chance of an update on this issue?
I’m getting really tempted to just completely bin the install and try starting over.

Kind regards,


Screenshot 2023-06-30 at 6.09.51 pm.png

Screenshot 2023-06-30 at 6.10.26 pm.png

Screenshot 2023-06-30 at 6.11.05 pm.png

Screenshot 2023-06-30 at 6.10.47 pm.png (3.23 KB)

Hi there @krackedkreative -

Thanks so much for your continued responsiveness & sharing everything you’ve experienced.

We have been able to reproduce this on our end, so I will be recategorizing this issue as a bug!

We don’t have an ETA on a fix, but it is on the Local engineering team’s radar.

Thank you,


Thanks Sam, no problem; grateful it wasn’t just me experiencing it…

Looking forward the update.

Kind regards,


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.