Plugin won't install - Help

What issue or error are you experiencing?

I have just downloaded WP Local and installed on my MacBook Pro M1. Program installed fine and I have been able to create wordpress site, log in and view them. But when I try and install a plugin from within the WordPress plugin store I get the following error: Installation failed: The package could not be installed.


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

I have created another wordpress site and get the same error.

System Details

  • Local Version:
    latest version
  • Operating System (OS) and OS version:
    Mac OS 13.5 (22G74)

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hey @greenwebsite – Welcome to the Local Community Forums!

That sounds like maybe there’s an issue with either how Local is connecting to the internet or something within the WordPress site itself.

Can provide the Local Logs? You can get a zip of those logs by clicking the “Download Local Log” button from the “Support” tab of Local. See this help doc for more information:

Those logs are for Local, but can you also provide the logs for the site? To do this, navigate to ~/Local Sites/<site-name> and zip up the logs folder.

Thanks for your reply. Please find attached the local logs zip file. I have also got the zipped log file for the site I have been trying to install plugins on.

Just as it might be relevant. I have put the wordpress files onto an external harddrive (in local wp I could choose a new location for wordpress and files to be stored, so I changed it to my external harddrive). When I tried to zip the log folder for the site, it wouldn’t let me zip up the folder with the log folder in the place it was. I had to copy the folder to my desktop and then I could zip it.

Hopefully, this is something simple to change, as I would like to start using this program.

Nic

local-logs1.zip (22.2 KB)

logs.zip (8.41 KB)

I’m seeing a bunch of errors in the PHP error log that seem like they might be related to Live Links.

How are you interacting with the site? Are you managing the site over Live Links, or more directly from the “Open Site” or “WP Admin” buttons?

Have you verified that this is an issue on a new, plain WordPress site? For example, if you create a new WP site, navigate to the WP admin and try to install a plugin, does that give the same error? If it doesn’t cause an error, then there’s likely something specific about this site that’s causing problems.

I have been using the “WP Admin” button and the “Open Site” button to load the website in a web browser (I am currently using safari as my web browser). I do have the live link enabled but only to test as I thought it was a really amazing feature.

I have just installed a new wordpress website and called it “Test 1”. I did not enable the live link feature. I installed it using the preferred settings. Once installed, I clicked on the “WP Admin” button and entered the username and password. Then I tried to install a plugin from the wordpress plugin, but I got the exact same error message. I have attached the logs again.

It seems like it’s not a site-specific problem, but rather a problem I’m having with all sites I create using Local WP.

local-logs2.zip (22.9 KB)

logs.zip (3.18 KB)

That’s definitely odd!

Can you include a screenshot of the whole browser where you see the error?

Also, is there a particular plugin you are trying to upload? What is the name of the plugin and the name of the plugin zip file?

Hey,

I have included two screenshots. One from me trying to install a WordPress plugin directly from the wordpress directory and one from trying to upload a plugin. Both ways failed.

Whatever plugin I try to install from the wordpress directory fails. I have tried uploading several (I have uploaded and installed on wordpress websites without problems) plugins. It doesn’t seem to matter what the plugin is.

Thanks for these screenshots, @greenwebsite.

Does it work if you create a site in the default location on your main drive instead of an external one? (You could try setting New site defaultsSites path back to /Users/[your.username]/Local Sites, then try to create a new site and install plugins.

The screenshots and your previous messages (below) suggest that permissions on your Local disk may not allow Local to write to it.

Hey.

I moved the default location back to my laptop hard drive and it worked. I can install a plugin from the Wordpress plugin directory.

Do you know how I can change the setting with the hard drive?

Thanks for your help with this.

Thanks for confirming that, @greenwebsite.

You could try adjusting the “Sharing and Permissions” settings for the drive so that at least your user and the “staff” group have Read and Write permissions. If they already do, you could try giving those permissions to the “everyone” group too, but I’d only do that if you need to.

1 Like