Portfolio projects not displaying

What issue or error are you experiencing?

Hi, I’m working at a new version of my website, so I imported the whole wp-content on Local. I’m using the Twentig plugin on WP-theme Twenty-Twentyfour because I have portfolio projects to showcase. Now I see them all on my dashboard, I can edit them, but any link or visualisation attempt leads to a “page not found” message.
What can I do?
Thanks!
error.log (17.9 KB)
local-lightning.log (2.5 KB)


What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc


System Details

  • Local Version: 9.0.1+6673

  • Operating System (OS) and OS version: macOS Sonoma 14.4.1


Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

I hope I got the right Logs…


Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @Satyrika

So you only imported the WP-Content but not the database?

Hi Nick,
yes, and everything is working fine - apart from the portfolio project.

When you check the console in your browser do you see any errors? It sounds like things just might not be synced up somewhere.

Hi again Nick, and thanks for your help.

As a matter of fact, it shows an error:
Failed to load resource: too many HTTP redirects

and then a warning:
The resource http://satyrikon-test.local/wp-includes/js/dist/interactivity.min.js?ver=6.5.2 was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it wasn’t preloaded for nothing.

Which I have no idea what it means… I don’t know, I’m already thinking of giving up the portfolio and find another solution for displaying the projects…

Hi @Satyrika

It sounds like you might have some plugins that could be interfering here. Do you have any plugins that force HTTPS, handle redirects or caching? You could try disabling all plugins if you’re not sure but that could further break formatting.

Hi,
I have tried disabling everything except Twentig, which is the plugin that allows my portfolio projects to be displayed in the backend at all. Nothing changes.
I’ve already written to Twentig support, they told me to try refreshing the permalink setting, but that didn’t work either.
Should I try to delete this local website and start again? Maybe activate Twentig before uploading the content? I also don’t think that Twentig could be the problem, because I’ve already tried a couple of portfolio plugins: some are even worse, in the sense that they don’t recognise my portfolio items at all…

A small update: I’m not sure what exactly happened.

I disabled Twentig to see if I could work on portfolio projects only through Jetpack, which I then enabled: they were gone in the backend too.
So I disabled Jetpack and re-enabled Twentig: now they’re in the frontend too.

Also: all little problems I had saving custom headers or custom templates with the theme editor are gone :flushed:

Maybe they needed a night to sleep on it? :slight_smile:
Thank you again for your support, your questions have definitely taught me a few things.
And now let’s hope that everything continues to work.
Bests
Roberta

1 Like

Glad to hear it @Satyrika! If you have any other questions or concerns don’t hesitate to reach back out. We are always happy to help!