Local Community

Problem with MySQL

I have done many searches through the DB through “Adminer” without on any problems. Then, I started getting the following error message:

Syntax error near ‘LIMIT 1’ at line 1

no matter what I’m searching for or whether it is one table or the whole DB. Any ideas?

1 Like

Hi @AlanS,

Sorry for the trouble!

Can you provide a screenshot of the error?

Also, what environment is the site running? Preferred or Custom? If the site’s running Custom, what versions of PHP and MySQL is the site running?

The environment is custom: Apache, PHP 7.1.4, MySQL 5.6.34.

Thanks!

Still hoping you can help, Clay!

I just did a test, and it looks like the problem is with Local by Flywheel: every one of my Local sites now has this problem.

More information: The problem seems to be with the update to Adminer. I had a Local site that not been running for a while. I started it up and, when I first went to check if I could do a search in the database, it worked fine! But when I went back to Local, the CLI and Adminer updates were automatically installed. Then when I tried another search in the database, the same problem occurred (“Syntax error near ‘LIMIT 1’ at line 1”). Is no one else having this problem?

Further testing: I exported all my sites (via Local’s export feature and also via the All-in-One-Migration plugin), then deleted the sites from Local, deleted Local, and then reinstalled Local. I tried reimporting one of the sites I exported, but I get a 403 error. Then I created a new site and imported via the All-in-One-Migration plugin, and the site opened without a problem. I also created a new site and left it as is, and it opened fine. However, the Adminer is still giving me the same error message, on both the new (essentially empty) site, and the site I migrated in.

To be clear, both the issue with the Adminer and the issue with the 403 on a site imported via Local are big problems.

Still hoping…

Incidentally, I have the same problem on my laptop and desktop computers, both Macs

@AlanS,

Are you running into this problem with sites running the Preferred environment?

Also, have you tried changing the PHP version on the sites you’re having trouble with to 7.2.0?

Same problem with Preferred environment, also with PHP 7.2, and MySQL 5.5 or 5.6.37

@AlanS,

Unfortunately, I don’t have a solution until more information surfaces.

As long as the sites are functioning fine, your best option right now is to use Sequel Pro. It’s free and substantially better than Adminer.

I assume it’s a problem with Adminer. When you say “until more information surfaces”, what kind of information do you mean? Do you think it has to do with the update to Adminer?

Thanks,
Alan

I’m just chiming in here that I’m getting the exact same issue running PHP 7.1.4, NGINX, MySQL 5.6, WordPress 4.9.4, Multisite with subdomains.

Sequel Pro is also not returning proper results when searching the database.

Actually, I take that back Sequel Pro is working alright, but Adminer is the same.

Same problem here with Adminer.

Maybe drop Adminer and support phpMyAdmin?

I was having this issue too on my Mac. Simple reinstalled the latest version and now it’s fixed.

Did anyone ever figure out a solution to this issue? I’m experiencing the same.

@cagross,

Sorry for the trouble!

What version of Local are you running and what operating system are you on?

Hi Clay,

I’m running Local v3.3.0, in Windows 10. My site settings are:

nginx
PHP v7.2.9
MySQL v5.7.23
WP v5.3.2

Thanks.

@cagross,

Thanks for the info!

Are you able to connect to the database using HeidiSQL?