Pull not working, maybe something weird with Flywheel

I’ve just tried to do a pull with Local of a site on Flywheel called Neofirma (www.neofirma.com). It pulled down most of the site, but seems to be missing some things (the top section on the home page, for example).

I tried pulling it down manually (grabbing a backup of the site), and it seems to be grabbing a different site that’s on the same account (grabbed the files from the other site and some of the database from each).

I’m not sure where to direct this, but I wondered if someone might be able to do a test pull of this site to Local and see if there’s something more obvious happening here than I’m seeing. This behavior doesn’t feel very predictable to me, but there’s, well, like I said, something strange going on.

Hey Jon,

I just tested out pulling and it was successful. I did see the header issue you mentioned but that appears to be related to the theme.

When I copied the contents of page-flexible-contents.php into front-page.php it fixed the issue. It looks like WordPress is selecting a different template when it’s pulled down to Local.

I’m not exactly sure why it’s selecting the different template after pulling. https://developer.wordpress.org/files/2014/10/wp-hierarchy.png and https://developer.wordpress.org/themes/basics/template-hierarchy/#front-page-display may be a good place to start if you’re curious though.

1 Like

Clay, that’s really fantastic support. That’s way above and beyond the info I was hoping to get.

Can’t believe I didn’t think of that (bizarre that the template heirarchy is different on the local install; perhaps the permalinks aren’t fully refreshing in this fringe use case). Thank you so much!!


Jon Schroeder
Elodin Design Inc.

1 Like