Pulling from WPEngine doesn't work


I am getting this error in the logs:

{"thread":"main","reason":{"message":"Unable to get 'home' option from WordPress.","stack":"Error: Unable to get 'home' option from WordPress.\n at ChangeSiteDomainService.<anonymous> (/Applications/Local.app/Contents/Resources/app.asar/main/sites/ChangeSiteDomainService.js:1:4331)\n at Generator.next (<anonymous>)\n at _0x3b191c (/Applications/Local.app/Contents/Resources/app.asar/main/sites/ChangeSiteDomainService.js:1:1624)\n at runMicrotasks (<anonymous>)\n at processTicksAndRejections (internal/process/task_queues.js:85:5)"},"p":{},"level":"warn","message":"Unhandled Rejection.","timestamp":"2020-02-01T04:12:05.675Z"}

It looks like a bug. Of course, the website works fine (at WPEngine).

Hoping to see this fix in the next release :slight_smile:

Hey @TigrouMeow

It looks like there was an issue with pulling the site down.

  1. The latest version of Local fixes a few things related to Connect with WP Engine. Can you try installing the latest version from the Releases page:
  2. If that doesn’t fix things, can you please provide your Local Log? See this Community Forum post for instructions on how to do so:

Let us know how that goes, or if you have any other questions!

Same issue as here in fact: How do I retrieve Local's log file?. It’s not related to WPEngine. It doesn’t work with any import. Too bad, it used to work really well. Since the new versions, it doesn’t. I will look into the logs but it seems like better error messages and conditional errors check should be written somewhere to make debugging easier or even get rid of the issue.

I am on the most recent version (5.3.1+3095) and it’s still broken, at least for imports from WP Engine. I haven’t tried a non WP site.

Tried again, with the latest version as of today, and still not working. The WP install on WPE is fresh and new, so it should really work right away.

Is SSH required? SSH is not enabled by default at WPE, and it seems like this process might require it, however Local is just crashing without any specific error message in its UI, which is should absolutely do.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.