Local Community

Provisioning from WP Engine Fails

I’ve attempted pulling a number of the sites on my account, and they have all spun and spun and spun. Even left one overnight, and had the same thing. It always freezes on “Changing domain name”.

When I examine Local’s logs, the last entry is this:

{"thread":"main","reason":{"message":"Unable to get 'home' option from WordPress.","stack":"Error: Unable to get 'home' option from WordPress.\n    at ChangeSiteDomainService.<anonymous> (/Applications/Local.app/Contents/Resources/app.asar/main/sites/ChangeSiteDomainService.js:1:4331)\n    at Generator.next (<anonymous>)\n    at _0x3b191c (/Applications/Local.app/Contents/Resources/app.asar/main/sites/ChangeSiteDomainService.js:1:1624)\n    at runMicrotasks (<anonymous>)\n    at processTicksAndRejections (internal/process/task_queues.js:85:5)"},"p":{},"level":"warn","message":"Unhandled Rejection.","timestamp":"2020-02-21T15:06:35.842Z"}

My first install of Local and a pull from WP Engine worked flawlessly. Now when I pull, I get the same error you’re getting. WP Engine should not be promoting this platform until it’s stable.

I can’t even push my site to WP Engine because Local doesn’t support pushing the DB!

Hi there, Local’s latest release 5.2.5 enables database pushing for WP Engine: Local 5.2.5

Database pushing was disabled while we tested and confirmed it was stable. Now after testing, we’re ready to ship this new feature!

Downloaded it. But now it hangs at Downloading and Extracting Files…

All I’m pulling is a Landing Page with a Thank You page from WPE. It’s nothing complicated or large. It’s about as simple as you can get.

Tried three times. No luck. :slightly_frowning_face:

I jumped on the command line and blew away the app in the Applications folder and all the files in my Library/Application Support/Local folder. I then attempted a clean install with 5.2.5. No difference. Pulling my two-page site from WPE still hangs.

Looking at the logs, I see a series of:

wpe_cli+db+pull+<SITE_NAME>@git.wpengine.com: Permission denied (publickey)
wpe_cli+rsync+pull+<SITE_NAME>@git.wpengine.com: Permission denied (publickey)

I deleted and re-generated my API access creds in the WPE profile. Still get same error. :thinking:

Got the download to work. I read WPE’s details on creating SSH keys for git since my logs showed key errors for git.wpengine.com.

Once I did that and configured and tested my access to git.wpengine.com via SSH, I was able to successfully pull down my tiny 2-page site.

Next test will be a push!

Push kinda worked… none of my images were pushed. My Library shows placeholders for the images, but when I click on them I receive a 404 Not Found.

I installed Better Search & Replace plugin to find all the instances of the Local URL on my Mac and replaced it with the NAME.wpengine.com URL. Still no luck.

At least the DB was pushed. It seems to work.

Hi there, Local Connect will handle SSH auth, search and replace, and many other steps automatically during the push/pull process. We do not recommend manual configuration: Local will do this for you.

Make sure to enable WP Engine’s API for your account. More on that here: https://localwp.com/help-docs/getting-started-with-connect-to-wp-engine/

Yeah, that’s all done. API enabled and working. However, images were not showing when pushed to WPE. WPE Support had to perform a search & replace, which fixed the issue. They suggested I use a plugin like Better Search & Replace. They said the changes were not made by Local’s push.

Looks like Local Support and WPE Support do not agree.

I can definitely followup with WPE support and clarify what happens during a Local push. We run a search and replace for you on push/pull. That said, we only replace the Site URL defined in wp-admin. You might have other URLs which our system won’t pick up that won’t get replaced like secondary domains or https/http inconsistencies.

I agree. If it can’t pull sites down from WP Engine then they should probably remove the advert from their site. And if I can’t pull from WP Engine, I’m sure not going to try to push to WP Engine. This tool is unusable currently.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.