Push to Flywheel breaking plugins on remote site

We pulled a site from flywheel to local and made some edits. Added pages and content to existing pages. Once we pushed the site back to flywheel, including the database a number of plugins started to crash the site. We later on tried another push from Local, after some other updates were made, in the hopes that the issue might correct itself. The only fix was to delete the problematic plugins and reinstall them, fixing the issues.

I’m wondering if it is a settings issue causing some odd mismatch between the Local environment and the Flywheel site.

System Details

  • Local Version:

  • Operating System (OS) and OS version:
    MacOs Ventura 13.4

I am unable to provide any logs at this time.

Hi @clerick

It’s tough to say for sure what may have happened with the details so far. There may have been some conflicts at play with the site, or some issues with the push. When you say the site was crashing, do you mean it was running into resource or server-related problems? Were there server errors or 500-type errors? Did you look into the logs to see what was showing there? On Flywheel you can view and access your error logs from the Dashboard. Errors related to things like memory, PHP workers, timeouts, plugin or theme fatal errors, etc wouldn’t necessarily be Local related but either something happening on the hosting side or a conflict on the site. Did the WP version or PHP version change between the Local and live site? Were any of the plugins updated or removed?

The plugins in question were causing critical errors in the site and Flywheel had to go in and disable them before I could even get Admin access.

This is an example of what I was seeing:

Warning: require(/www/wp-content/plugins/safe-svg/includes/safe-svg-settings.php): failed to open stream: No such file or directory in /www/wp-content/plugins/safe-svg/safe-svg.php on line 104 Fatal error: require(): Failed opening required ‘/www/wp-content/plugins/safe-svg/includes/safe-svg-settings.php’ (include_path=‘.:/usr/share/php’) in /www/wp-content/plugins/safe-svg/safe-svg.php on line 104

The WP versions for both Local and Flywheel are 6.3.1. Local PHP is 8.1.9 and Flywheel was 8.2, but I did roll back to 7.4 to test compatability. I have deleted and reinstalled the offending plugins and that does fix it but knowing how to fix it isn’t very satisfying if i can’t find a root cause.

I’m open to the idea that there is some best practice that wasn’t followed since our use of Local, until recently, was quite limited.

Thank you for the reply

Similar to what I mentioned above, Fatal or Critical errors are usually the result of a conflict between the site’s plugins, theme or other configuration. The error you shared itself is kind of generic and shows up often in WordPress development. This article below might help shine some light on a possible culprit, but as far as it being the result of any Local specific workflow I can’t say.

I’m not as concerned about the errors that I was getting as much as the fact that they worked when the site was spun up, worked on Local when pulled down but broke when changes were pushed back to the live site. Deleting and reinstalling the plugins that were throwing the error resolved my issue but that was likely a symptom of something else. That’s what i was hoping to focus in on.

Was the only plugin that was causing the issue the safe-svg one? As far as throwing errors and needing to be reinstalled? That’s the only one I see mentioned in the error. Have you tried reaching out to the plugin developers with that error for insight? We always try and go above and beyond, but errors like these are generally best supposed by their dev/support teams. If they have any feedback or questions that we can help with let us know!

No, there were seven total. Yoast, Google Site Kit, The events Calendar amongst others.

Again it’s tough to say without further data to dig in. If this issue were happy to arise again, I would use the help article below to pull your Flywheel error logs to be able to see what slow/critical/fatal errors might be cropping up to help find some culprits. If you reach out to Flywheel support they can also help you pull recent errors.

From the Local side of things, as you mentioned things were working fine in Local. If something odd happened during the push we’d want to look at all the local logs to see if anything stands out. You mentioned at the beginning you didn’t have any logs to provide, so in the instance that something similar occurs again please click the Download Local Logs button from the Support tab in Local. This will generate a zip archive that contains the Local log along with some other diagnostic information to help quickly zero in on any issues that Local is encountering.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.