Pushing from local hangs on "dumping and pushing database" step indefinitely

When trying to push a local copy, no matter what I do, it hangs on the database step (dumping and pushing). It worked last week, so I’m not sure what happened. All I did locally was add a couple posts, a page, and a template file. Just standard changes would have been made to the database that come along with adding new content.

The database is only about 16mb, so the size of it isn’t an issue. Local is on the latest version and I tried restarting it a few times, then I restarted my computer as well. I’m on Windows 11

I restored the dev site to back when it worked, but that didn’t do anything. I hadn’t used the staging environment in a while so I tried pushing it there, same result. Then I deleted the staging environment altogether and tried pushing to a fresh install but again, same result.

Finally, I tried copying the live to the dev site and when that was complete, I tried pushing to the dev environment and it still won’t work.

It usually would only take a few minutes at most, but I’ve left it running for about 40-45 minutes and thought maybe it worked but the application was bugged. When I go to the site, it redirects to the WP installation

When I contacted WPEngine’s support, they either said to just keep waiting or directed me here, so they weren’t very helpful. They usually are, but not in this case.

I’ve attached the zip of the log files, hopefully someone can help

Local Logs

local-logs.zip (958.3 KB)

Hi @stinkysGTI

Has anything changed with the network you’re on? Do you use an office network for example? Or a VPN? If it was working normally and suddenly ran into issues that’s just a thought of some connection interference like a throttling or a firewall.

As another test can you try these steps?

  • Log out/disconnect from WPE within your Local app
  • Quit Local
  • Restart your machine
  • Re-open Local
  • Log back into WPE account and try again

Hello @Nick-B ,

Nothing has changed with my network and it’s my home network. I’m also not using a VPN

The other day after I posted this I left it overnight and at some point it went through. No idea when and I didn’t check it for almost 24 hours, but I can’t have it be that way moving forward. It’s just not practical for a site that has frequent updates (or in any case really).

Earlier I just made some file edits and pushed it without including the database and it worked as expected. Then I tried changing a file just to trigger an update and included the database. It’s been going now for about 30 minutes and is again stuck on the database step.

I have tried logging out, in, and restarting. I’m not sure what else to try

Hi @stinkysGTI

Some other things to check:

Are you running other developer applications simultaneously? That could also cause similar issues. Apps like MAMP, XAMPP, or Docker for example.

Do you have any antivirus, security, or firewall applications that could be blocking Local?

Do you have multiple sites running in Local at once?

Are you able to test from a different network just to completely rule it out?

@Nick-B
To answer your questions:
I only have Local running
It’s not blocked, it just hangs on the database step. It uploads the files just fine
Sometimes I do, but in this case, I only have the one site running
I would need to pack up and go to a coffee shot or something to test out another network

At home I’m hard wired to the router and have a 1gb connection (actual 750-800mbps). I left it running for a while and this time got the “oops error”, then I tried a different site because I hadn’t tried that yet. It still hung on the same step, so I left it for a while and it had finally went through.

I think I’ll try uninstalling and reinstalling it

@Nick-B
I tried uninstalling and reinstalling, but that didn’t change anything. I pushed another test and took about 2 hours.

I have some custom tables in the database. Is there a way I can exclude those? One of them doesn’t hold a ton of data, but has a lot of rows (almost 2million rows) and is about 80% of the total database size. I actually don’t want to be overwriting that one anyway because it gets changed on the front end of the live site.

If it’s unnecessarily going through that table I can see that causing a hang up

Hi @stinkysGTI

Yep you’re correct those db tables are likely the source of the hang up here. Do you need to push the database at all or could you just exclude the DB?

If it’s not needed I don’t but sometimes I do, like when I add pages, edit menus, etc. Some of the sites have localized versions as well so some text edits are actually 5-7 edits across multiple pages and I don’t really want to do all that stuff twice and verify that it all matches every time.

I ran another test with a different site that has a similar, but not nearly as big, table and it hung up as well.

Then I ran another test on a site that just has the standard WP tables and it worked as expected. So I finally found the issue. It just really hates custom tables.

Is there a setting file I can modify to always exclude non-standard WP tables?

Also, if I were to just remove the custom tables from my local environment would it drop them from the server like a regular file or would it just ignore it? I assume it would drop it but hoping not

You’re correct that if you removed the custom tables from your Local environment and then pushed the site up to WPE it would drop those on the hosted site.

We don’t have any customization options as you’ve described in Local. For what you need your best bet might actually be to utilize a plugin like WP Migrate DB for these specific sites versus using Local Connect.