Randomly getting "Your connection was interrupted" error since i updated to Sonoma

What issue or error are you experiencing?

Hi! A couple of days ago i upgraded to MacOS Sonoma(running 14.1.2 currently), and when i use any of my local sites, i keep getting this error in Chrome:

(text for search: Your connection was interrupted - A network change was detected. - ERR_NETWORK_CHANGED)

It happens intermittently, meaning i can still use the site, but i can see the problem after 5-10 page changes. Chrome auto-reloads after i see the error and then its fine again for a couple of seconds.

It’s not a browser issue, because same thing happens in Safari, although theres no error message there, it just fails to load the page and shows a blank screen.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Sadly i don’t know. What i tried to fix it:

  1. Restart my router/ISP modem
  2. Re-install Local
  3. Tried to create a new site
  4. Switching router mode to localhost seems to resolve the problem, but obviously not a good solution long time
  5. Happens with live links enabled too
  6. Tried switching between apache and nginx and different PHP versions, doesn’t seem to make a difference

System Details

  • Local Version: Version 8.1.0+6514

  • Operating System (OS) and OS version: MacOS Sonoma 14.1.2 (23B92)


Local Logs

I cleared the logs and clicked around on the site until i saw the issue, but i don’t see anything in the logs related to this problem. Any tips how can i help debug this problem? Thanks

Hey @passatgt – thanks for posting this!

I haven’t upgraded to Sonoma yet, but I have seen that error occasionally in other situations (ie, not with Local).

The steps you outlined seem like good ones. The fact that using ‘localhost’ Router Mode fixes things points to the Router (ie, the Nginx proxy that resolves example.local to localhost:10010) as the issue.

That sort of makes sense since I usually associate ERR_NETWORK_CHANGED as associated with DNS or networking issues.

I wonder if there’s a bad configuration in there?

In terms of what logs to review, you can view the router log by clicking “Help > Reveal Local router’s logs”

Let’s try deleting the config and letting Local re-generate it:

  1. Just to be safe, backup important sites by right-clicking on them and selecting “Export” to get a zip backup of them. Might be a good idea to backup that Router log as well.
  2. Quit Local
  3. Navigate to the ‘run’ folder located at ~/Library/Application Support/Local/run
  4. Delete the router folder
  5. Start Local and start a site to see if there are still issues

Can you give that a shot and let us know what you find? If you still have issues, I’d be curious to look at that router log.

1 Like

Hi! Thanks for your reply. Deleted the router folder, but sadly the issue still persist. I also tried to check the router logs, but it’s empty. Any ideas to troubleshoot?

I wonder if there would be more details in Chrome’s network logs?

Can you try starting Chrome with debugging enabled and then see if there are more details in the chrome_debug.log?

Thanks for the suggestion, however i have an update on the situation: i was thinking what else i did during upgrading to Sonoma and one of them was updating Xcode. So i uninstalled it, did a fresh install and now i don’t see the issue anymore. So looks like problem solved hopefully!

Thanks!

2 Likes