Setting max_allowed_packet

Issue Summary

Trying to set max_allowed_packet higher than the default 16mb

I’m doing this as when trying to import a large database I’m getting:

ERROR 2006 (HY000): MySQL server has gone away

The log states is due to exceeding the max_allowed_packet size, which is why I’m trying to increase the size. DB export is only 96mb after removing some high row count tables, so I’m confused as to why it’s failing with this error.

Troubleshooting Questions

I’ve tried setting this in the site php.ini.hbs, and even in the AppData\Roaming\Local\lightning-services\mysql-5.7.28+4\conf\my.cnf.hbs, alongside both restarting Local and even rebooting the system.

However, running a SHOW VARIABLES LIKE ‘max_allowed_packet’; via Local Site Shell it still reports 16mb

System Details

  • Latest Local

  • Win 10 64bit

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.