Site directs to no matter what

Hi, having issues trying to run local on one of my flywheel sites (that’s already been created/edited on Flywheel prior to bringing down to local). Here are the steps I’ve taken:

  1. Started a local by flywheel site, using php 5.6.20 and apache server (everything else default).

  2. Download a backup of my site from flywheel. Replace entire wp-content folder in local site with that of backup.

  3. Open up database .sql file in text editor, find and replace all instance of “” with “” (local URL).

  4. Import database.

When I try to visit the URL, it redirects me to every time. I have been using this workflow for another one of my sites with no problem whatsoever so I am a little confused why this is a problem. Maybe I am going about this the wrong way?

Is an existing Local site or is it the domain for the site you imported?

If it’s an existing Local site have you tried restarting

Sorry for the trouble!

Nope, is not an existing local site :\ Yep I’ve restarted multiple times. I’ve even downloaded local on another computer and tried this whole process – no luck.

It sounds like there’s a discrepancy between what the actual site domain name is in Local and what your WordPress options are set to.

Can you try dragging and dropping the Flywheel backup file directly onto Local? It should give you an option to create a new site with the backup.

It turns out there were some references to in my database. Not sure as to why that happened, but I went ahead and changed it out and now it works!

1 Like