Site importing is impossible (wp-config & sql database)

Hello everyone,

I will try to be as clear as I can, as English is not my mother tongue :slight_smile:

After reinstalling my macOS, I wanted to reinstall on flywheel the website I was working on (last backup was in October 2018, don’t remember which configuration I choose).

When I import the site using File > Import site, a message tells me: “Your wp-config.php file has an empty database prefix, which is not supported.” I tried to change my new wp-config.php by the old one, and I get into the WP dashboard. The problem is that I no longer have my media or the pages I made.

I have all the files and a backups folder with the sql database. But this one is a zip file which decompresses in cpgz, very light file of 143ko.

I tried to go through the terminal that announces that “the specified directory is not a mydumper backup” and tried several decompression software but nothing works.

I also tried to move this file in a sql folder placed in the app folder without success. Same thing when I try to import the sql file in local admin, it shows me: “Error in the query (1064): Syntax error near ‘PK’ at line 1”.

During the installation I tried several versions of mysql (5.5, 5.6, 5.7) without success. I also tried to create a site with the same name to replace it with the old one. I read several posts in wordpress and flywheel forums and I really think I have tried everything.

Do you have a last suggestion to restore this site?

Thank you in advance for your attention and help.

Audrey

Hey @audreydl, welcome to the Community!

That’s definitely odd, so let’s see how we can help!

If you have the original site folder which contains the app and the logs folders, you can try using the files for the site to restore by following the steps outlined in the “Restoring From Only Local Site files” section of this help doc:

Another option is to try and get only the sql file and the wp-content folder so that none of the default WordPress core files are attempting to be imported.

Let me know if following the steps in the help doc gets you a site that is working in Local, or if you have any other questions!

Hello Ben and thank you for your answer!
Unfortunately I already tried theses two methods, I think my sql file is corrupted.
With the two methods I have the error message : "Your wp-config.php file has an empty database prefix, which is not supported.”.
I don’t understand why the sql file I have is zipped without nothing inside it… Just a cpgz file.
Have you seen this kind of file before ?
I think I must start my website again…
Thank you a lot for your attention!
Audrey