Site Logo feature is not presented as option

I am using a Theme that supports the Site-Logo feature… yet, the Site-Logo feature is NOT presented as an option in the Site Identity panel.

I have updated everything: Local by Flywheel, WordPress (4.7.5).

I got this Theme from where I have just begun to explore WordPress. When using, the Site Logo Feature IS presented in the Site Identity panel.

Is this just a bug in Local by Flywheel?


Hi Scott,

Can you link to the theme you’re trying?

I have two Themes I’m playing with:

Both of these Themes allow me to use a Site Logo… when I am in

Local by Flywheel does not provide this feature.

Thanks Clay.

Hi Scott,

Themes are usually different between and There are different requirements for themes to be on vs. the theme repository. is more strict about themes using existing WordPress functionality and not their own.

I just tried the Gateway theme and found the logo option under “Header” in the Customizer.

Are you referring to the ‘Header Image’ Panel in Customizer? And are you in Local by Flywheel?

Just to be clear, the Header Image is not the same thing as the Site Logo. The Site Logo is documented to be a feature within the ‘Site Identity’ panel (in Customizer).

Yup! I tried the Gateway theme in Local.

Please see what I mentioned about themes being different between and It’s not a bug in Local, it’s simply how some themes are [slightly] different for and

The themes on go through a much more rigorous review process since the themes are actually ran on’s infrastructure instead of any server than can run WordPress.

It’s very, very confusing to say the least!

Clay, by any chance could you show me a screenshot of ‘where’ you found the logo feature? Appreciate it!

I do not see a ‘Header’ Panel in Customizer… just a ‘Header Image’ Panel. Is this the area you are referring to?

How did you install the Gateway theme on your Local site? I went through Appearance » Themes and installed it from there.

I downloaded a zip from, then manually installed that Zip file.

Note: when I ‘search’ for Themes, I get following message:
“An unexpected error occurred. Something may be wrong with or this server’s configuration. If you continue to have problems, please try the support forums.”

IOW, when I ‘search’ for Themes, I get that error and zero results. My solution was to manually download and install the zip file.

You can resolve this by going to Help » Restart Local’s Machine. This will reinitialize the virtual machine’s network device.

Is this the theme you downloaded? Gateway – WordPress theme |

Here’s what I see in the Customizer:

Clay, just an update. I got ‘gateway’ theme to work by re-downloading from the link I sent you… which turned out to be slightly different link than what I had previously downloaded.

Turns out I really need the ‘lodestar’ theme to work with a Site Logo… and it doesn’t.

So, I’m having to re-strategize my plans.

BTW, Flywheel site mentions a Free Trial. Is there a link to get actual details on the Free Trial?

Hi Scott,


Thx Clay. Thought I had seen a page on the Trial… just couldn’t find when looking for it.

1 Like