Site Migration Via A Duplicator Zip File Did Not Copy All Files


In a search on this site I found an entry by Clay that said one can import a Duplicator backup by dragging it onto the Local By Flywheel icon in the mac dock. I did this and it ran to completion. I was asked for my password once.

However, it did not bring in any of the installed themes or plugins which made the site useless. I deleted the site and tried again with the same result. This time I installed the parent theme & child theme and the plugins. I activated the plugins and the child theme. The site now displays very partially. I then discovered that none of the media files were installed. It appears that just about none of the wp-content directory was installed.

I appears that the database is OK. When I first went to Appearance-Themes the missing child theme was indicated as the active theme and when I first went to the Plugins-Installed Plugins there was an entry for each missing plugin stating that the plugin folder could not be found. Also when I go to Media-Library there is an entry for each missing image with what would be the correct path to the file if it had been correctly imported. The Alt Text is also there.

The Duplicator file is good as I successfully uploaded it and the installer.php to a cPanel site and ran a flawless installation.

Can I copy installer.php & the … files to an empty …/sitefolder/app/public and then execute installer.php? If so, what is the correct procedure. If not, why not?


This exact same thing just happened to me … the child theme was there and labeled as active when I first clicked on themes, but when I cleared my cache (site loaded as blank), the 2017 theme came up and my child theme is no longer in the menu.

Same with the media files - they’re “there” as in listed and with alt text, but the images aren’t visible. Any help would be appreciated.



At least I know I am not the only one.


Hi all,

Sorry for the trouble!

What version of Duplicator are you creating the package from?

In the meantime you can create a fresh site in Local then use installer.php to import the site.

Hi Clay,

Duplicator 1.2.0.

I just created a new Local site:
= then deleted the contents of app/public directory
= then copied the zip archive and installer.php into app/pubic
= then executed installer.php and set the URLs with https://
= it ran seemingly successfully
= however, when I go to the site both Firefox and Chrome eventually stop citing to many redirects
= when I clicked on the Duplicator “Save Permalinks” button I did get a Wordpress login screen as was able to login
= however, trying to view the front end while logged in still stops, citing to many redirects
= while going through the settings on the back end, I got a popup saying that the Wordpress session had timed out and gave me a link to the login page, however this time the login page is having trouble loading

I just used the Duplicator zip archive and installer.php to do an installation on an XAMPP localhost site. It ran flawlessly and I have no problems going to either the front end or the back end of the site.

This means the Duplicator install ran OK on a cPanel account and on an XAMPP local host, but not on Flywheel Local.


1 Like

It’s working fine for me… But we are in 2018 and it’s not the same version of Duplicator. I’ve made a mistake at firts try (due to habit of Wamp) : the password of the DTB is not empty but root by defaut in flywheel


It is now two plus years later.

During this time I have been using AMPPS on macOS with no issues, until recently. macOS started issuing warnings about 32 bit components of AMPPS. When contacted, the AMPPS folks gave me a kind of we’re working on it reply. Then AMPPS starting going bonkers.

I have Duplicator backups of all my sites. So I tried my Local by Flywheel install again, after updating it. I created a test site and then deleted all the files in the site directory. I then copied a Duplicator zip file and installer.php into the directory. I then navigated to the site via Local by Flywheel and executed installer.php. And it ran well!!!

I have now migrated over a dozen former AMPPS sites to Local by Flywheel and all are running as expected and I am able to manage things such as PHP versions for each site through Local by Flywheel with no problems. So far so good. Note that I did not (and probably will not) try to drag the backup onto the Local by Flywheel Dock icon. I am fine with the create, delete, copy and execute procedure.