Sites refusing to start after latest update 2.0.1

Installed the update and clicked on " > " button next to the site. It popped up " (HTTP code 500) server error - Unknown runtime specified default" and went into perpetual state of 'Starting…". I checked the logs and here the entry -

May 31, 2017, 7:22 AM GMT+5:30 - error: [main/startSite] Error: (HTTP code 500) server error - Unknown runtime specified default
at /Applications/Local by
at getCause (/Applications/Local by
at Modem.buildPayload (/Applications/Local by
at IncomingMessage. (/Applications/Local by
at emitNone (events.js:91:20)
at IncomingMessage.emit (events.js:185:7)
at endReadableNT (_stream_readable.js:974:12)
at _combinedTickCallback (internal/process/next_tick.js:74:11)
at process._tickDomainCallback (internal/process/next_tick.js:122:9)

Would appreciate if you could provide a quick fix.

@TheBigk I got same error too.

Did you find any fix? I tried replacing the app with a fresh download; but the error continues.

@TheBigk For quick fix: cloning is working fine.

DIdn’t work for me. Removed everything and starting afresh. Add 30 minutes of extra work.

I’ve got dozens of local sites. removing them and starting fresh is a MAJOR pain. hoping there’s a better fix, since I’m experiencing the same error.

1 Like

Same problem here :frowning: Also, none of the site configurations are editable.

Same issue here, all sites prior to upgrade now do not work. New sites created work as normal. Also tried cloning existing but stuck in a perpetual load.

If anyone is having this issue please see this thread:

Thanks! The 2 lines of code worked. I had to also change the site url in the database as it had changed it to a .local URL.

1 Like