Slow and 504 errors

I’m having speed problems with my Local install and seeing 504 errors. The sites are pretty much unusable it’s so slow. I tried disabled Xdebug which did not work. :frowning:

I have a brand new (2015 model) 16gb Macbook Pro.


Here’s a screenshot of the 504 error.

Hey Clark,

This happened to me at first with my Windows version, and I just enabled Apache instead of Nginx, restarted the server and it worked.


Hi Greg

Thanks for taking the time to reply. I tried swapping to Apache and it seems to have fixed the 504 error but the site it still extremely slow.


Any updates on this? 504 and very slow. Any logs we can check to see what is happening?

Hi all,

Site speed is dramatically increasing in the next major update to Local.

Also, @bluedogdigital, did you restart the site after changing the php.ini file and then verify your phpinfo()?

1 Like

Hi Clay. I was unable to fix the issue, so I rebuilt my Mac and now it’s working OK. Thanks.

I’m experiencing the same problem @clay. The load time for my page was 54 seconds. The load time after editing the php.ini file was 1.4mins.

Any other suggestions?

Hi Job,

What change did you make to php.ini? Have you tried disabling the Xdebug extension?

You mean this? Speed Issues on Local Machine

Yeah, I added the semicolon before the zend_extension = /opt/php/7.0.3/lib/php/extensions/no-debug-non-zts-20151012/ line

Hi all,

Be sure to check out Local 2.0. It has various site performance improvements.

For more info check out Local by Flywheel 2.0.0 (Pre-release)

So I’ve found a way to solve it (temporarily) - as soon as I turn my internet off, suddenly the speed is amazing. I just can’t afford to have my internet off the whole time.

Busy downloading 2.0 and will see if that solves it. @clay

I’ve just set up a new local site with a different local URL and this one is working fine without problems. I’ve tried deleting the other one and reusing that old URL but it keeps being horrible. I can continue with the new site, but would be interested to see what is happening with the other one (config was exactly the same btw)


One thing you can try is the Airplane Mode plugin. This will disable outbound requests from WordPress entirely:

If you want to dig deeper and find the slow request, you can use