SSL Trusted but Not Secure in browser


I have activate the SSL on my Local website however in the browser it still shows not secure.

I have a fresh install with just one plugin installed. [Super-Progressive-Web-Apps]

At the plugin settings I get this info:

Progressive Web Apps require that your website is served over HTTPS. Please contact your host to add a SSL certificate to your domain

Anything else I need to do besides activate SSL as ‘trusted’


What browser and OS are you using?
There’s a known incompatibility with Firefox and macOS.

MacOS latest version and Chrome Latest Version, also tested on Safari

UPDATE: It is working now on the frontend, but not on the admin.

Could you make sure that your your WordPress and Site URLs are set to use https? You can edit this at /wp-admin/options-general.php

Another thing to check, go to Local’s SSL tab and click Trust. Did that help?

Here’s a couple more tips:

I changed the URL on the General Settings page and now Admin also has the padlock.

Question: I am trying to see the website on the mobile using Live Link, should the SSL works with it as well? Cause I see it Not Secure.

SSL isn’t available on Live Links powered by ngrok.

We’ll be launching a major upgrade to Live Links later this month (stay tuned), and it will enable many new features like SSL, added security, and higher connection limits.

1 Like


Thanks for your time and help!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.