Stuck on Changing Site Domain

What issue or error are you experiencing?

When cloning a site I get stuck on Changing Site Domain. I have also tried to export and import a site zip, and then I get an error relating to my.cnf :sob:

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

Clone a site, any site.

Error: Error: Command failed: /Users/xxx/Library/Application Support/Local/lightning-services/mysql-8.0.16+6/bin/darwin/bin/mysqld --defaults-file=/Users/xxx/Library/Application Support/Local/run/0btCt5IC0/conf/mysql/my.cnf --initialize-insecure

mysqld: [ERROR] Failed to open required defaults file: /Users/xxx/Library/Application Support/Local/run/0btCt5IC0/conf/mysql/my.cnf

mysqld: [ERROR] Fatal error in defaults handling. Program aborted!

at ChildProcess.exithandler (node:child_process:422:12)

at ChildProcess.emit (node:events:517:28)

at maybeClose (node:internal/child_process:1098:16)

at Socket. (node:internal/child_process:450:11)

at Socket.emit (node:events:517:28)

at Pipe. (node:net:350:12)

System Details

  • Local Version:

Version 9.0.3+6684

  • Operating System (OS) and OS version:

Sonoma 14.5 (23F79)

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @dikdronk

On the site you are trying to clone/re-import what is the PHP version? If it’s not already can you try changing it to PHP 8.2, refreshing and then see if that works?

That worked! Thank you so much!!

1 Like

Glad to hear it @dikdronk! Thank you for following up. I believe there was a bug we uncovered not too long ago involving some of the older PHP versions but the newer ones work fine.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.