Stuck on "Starting Local Machine"

I recently had a black screen of death appear followed by restarting my few months old macbook pro while working on a project and using local. after the restart local locks up on the “Starting Local Machine” screen.

Since then I have tried -
*going to help>restart local machine
*deleting local from my applications folder, emptying my trash, and re-downloading it.
*doing a full restore in time machine from a backup I made yesterday.

nothing seems to have worked, I am still on “Starting Local Machine”. as far as I can tell everything else on my computer seems to be working fine.

also just tried this and still no success How do I uninstall Local on macOS?

I’m having the same problem… Was there a reply here?

Me too…now I just want to get rid of it…the whole thing is making me nervous

Why is there no replies?

Supports not great is it!

Hi Susanna, no and it’s a shame because I’d like to use local by flywheel and learn why it gets stuck. The reviews for this App are quite good online. But as a relative newbie I worry it is making some weird changes to my Bios etc on my machine…I’m sure the community could help each other’s here…is anyone out there?
I am running Windows 10 and i7procesdor on a fairly new machine…