Testing on Local -- 404s, but not when logged in?

What issue or error are you experiencing?

I am testing on Local for the WP Engine mySQL 8.0 upgrade.

Some pages are not rendering and redirect to 404s.

What steps can be taken to replicate the issue? Feel free to include screenshots, videos, etc

On my own site, I have found that the pages redirecting are custom post type pages.

However, I discovered that if I log into the admin and then view these pages, they work fine.

Could it be a rewrite issue?

I tried re-saving permalinks, just to see if that could help. Then I logged out. Yep, then the page worked.

Is this a known bug?

System Details

  • Local Version:


  • Operating System (OS) and OS version:

Windows 10

Local Logs

Attach your Local Logs here (Help Doc - Retrieving Local’s Log)

local-logs.zip (14.2 KB)

Security Reminder
Local does a pretty good job of scrubbing private info from the logs and the errors it produces, however there’s always the possibility that something private can come through. Because these are public forums, always review the screenshots you are sharing to make sure there isn’t private info like passwords being displayed.

Hi @relish27

Not so much a bug as just a common WordPress development issue that users will see from time to time:

How to Fix WordPress Posts Returning 404 Error (Step by Step).

Thanks for the input. Yes, that’s why I gave it a try here.

I was downloading several sites from WP Engine for the mySQL upgrade and noticed it happening repeatedly on almost all of them, so I added it to my Local testing workflow. I would not have expected that necessarily when I got started with Local, so I thought I’d post about it in case it helps others.

1 Like

10 sites down (mySQL upgrades)… only 40 left to go! :sweat_smile:

1 Like

Thank you for sharing your findings for others! Hopefully your next 40 sites go smooth and you’re done quick :green_heart:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.