The new update killed local. *update*

I have ten site on local and non of them work.
this is what i get now

This site can’t be reached

pizza-shop-clone.local refused to connect.


i reinstalled local (nothing) i reinstalled virtualbox (nothing)

this is the log please help ive put alot of work on those sites
local-by-flywheel.log (233.3 KB)

  • Update the new update has fixed all the problems and all of my old site are working again.

This happened to me, Yesterday I was able to just about open one site after restarting local but today it’s a no go. Nothing wants to work properly. The one site i tested upgrading now won’t even finish loading.

So I’m spending the day transferring all my sites off local. Auto updating local server software is just fucking stupid. Nice way to have a totally inconstant environment.

No matter how useful Local is, this is by far the worst software I have ever used when it comes to updates. Each update breaks everything, and sometimes I wasted whole day to bring it back up. And, today, again, it is broken, it can’t uninstall at all. I would like to see a new version with no new feature, just a working install and update.

1 Like


Thanks for the error log. It looks like Local is running into an error when trying to copy the MySQL config into the site’s container. Can you provide a screenshot of the files/folder in C:\Users\louie\Local Sites\pizza-shop?

Also, if you create a brand new Local site, are you able to access it?

@Ahoy @dev4press,

I’m truly sorry for the bad update experience(s)!

If you can provide additional details such as operating system and environment versions (Preferred 1.3.0 for example), we’d greatly appreciate it.

After 6 hours, 4 re-installations for Local and/or VirtualBox, it works again. I had 2.4.0 version, updating to 2.4.2 today, on Windows 10 x64 Home (1803), I used environment 1.3 that was installed with 2.4. Update and install process is truly awful, and every attempt was different, breaks at different progress points.

I did create a new site and I can’t open it either. Once I get home I can send you the file

Same here, yesterday it worked fine, today, no go! So much for spending my time today productively.
Also, I can’t create a new site, version.php does not exist.
php-fpm.log (627 Bytes)
error.log (1.1 KB)

I’m having a similar problem, but I am able to make and view new websites. Just not the old ones before the new environment.

error.log (46.0 KB)

Same issues here, reinstalling helped, but pushing seems to have errors, the admin password does not work and the entire menu of my site has disappeared.

Now it won’t push at all.06

I’m running local on an iMAC, OS X 10.13.6 (17G65)


None of my sites will load, and creating a new site from scratch didn’t work either. I also tried reinstalling the Local app, restarting computer, to no avail. Older sites that haven’t had the ‘environment update’ applied also do not load. All return the ‘ERR_CONNECTION_REFUSED’ message. Please Flywheel, help.

Same problems here. Very disappointing.

Has anyone successfully reverted back to a previous version and got it working? I just tried reverting back to v2.4.0 and restored my backup of [user]/Library/Application Support/Local by Flywheel/ but it’s still not working. Is there some other directory I should restore from a backup?

It’s really unbelievable how LBF wrecks itself.

1 Like

Yes over two weeks of breakage and no help from Flywheel.I have not uninstalled and reinstalled twice with no luck.

I was able to get it working again by completely removing Local and it’s support folder, updating VirtualBox to the latest version, and reinstalling Local. Problem now is that I have to manually recreate all of my sites.